Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Batch Macro not returning a sheet in live environment [SOLVED]

Highlighted
7 - Meteor

Morning folks,

 

I've hit a solid wall here and wondered if you guys could shine some light on this.

 

I've built a batch macro that will take a file directory location and sheet name extracted from a directory tool (that scans a large portion of our network drive) and then return the various excel sheets that are contained within. Now, I'm aiming to extract three different sheets from the same files (Different schema unfortunately so can't all be in one) so I have three macros setup to extract "Sheet1", "Sheet2, "Sheet3"

 

In testing, all three sheets will be extracted from the list of files accurately. However in production the "Sheet3" side of things just won't pull anything. It just returns a blank and I've tried every which way of trying to get it to work.

 

I've even taken a file from the live environment (Our network drive) and placed it onto my testbed environment (also our network but all centralised in a folder) and it works fine! But aiming at the file in question on the live network drive does not pull back any data! 

 

You can see why this is so irritating I bet?

 

So. Any thoughts, Logic, Problems where this has happened before would be fantastic!

 

I can't really attach a workflow to this as the data can't be replicated and is a tad confidential so I've attached a screenshot (Imgur link, sorry) and hopefully you can extrapolate how it operates. Screenshot

 

EDIT: Nevermind. The actual macro doesn't return results without a tool attached at the end. Foolish of me.

Labels