Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Attempted to skip more lines than in the file

8 - Asteroid

Hi There,

 

I have an Alteryx query that imports 5 files a week all of which has a separate workflow for each but all within the same workbook. I have been using this workflow for 6 months with no issues and all of a sudden am getting the following error message "Attempted to skip more lines than in the file. Please check the import line". I have seen a couple of discussions in the community site but were over a year ago and was wondering if this "bug" has been fixed.

 

The first 2 rows in the file have file names and dates etc.. and do not need these and the third row is the row header. The workflow is set up to start importing from Row 3 and first row is the header row. The error is to do with the first 2 rows for some reason it does not like these. I can open the files and delete these rows and adjust the import row from Row 1 but this is very time consuming as each file is approx. 1m rows and takes a long time top open the files to do this manually.

 

Does anyone know how to work around this?

 

Thanks

 

Highlighted
Alteryx
Alteryx

Hi @collinjd,

 

Thanks for your question! Instead of using the option in the Input Data tool, can you instead try adding:

 

1. Sample Tool - "Skip First N Rows" N=2

2. Dynamic Rename - "Take Field Names from First Row of Data"

 

Let me know how it goes!

 

Amelia

Highlighted
8 - Asteroid

Hi Amelia,

 

Great thanks for this, I have added these steps and now is working as it should be.

 

Many Thanks

Jodi

 

 

 

Highlighted
Alteryx
Alteryx

@collinjd I'm glad to hear it!

Labels