Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Check out our powerful new search update! You can read more here. Please let us know if you have any feedback by creating a topic here.

Arithmetic overflow error converting varchar to data type numeric - pushing data to SQL

Highlighted
Asteroid

I cannot figure this one out!  I have a large number of transactions Im trying to load into a MS SQL DB, I have only 3 numeric fields and 2 of them generate the same error (If I deselect Price and Quantity the error disappears, adding one of them back in makes it happen again).  I have tried everything I can think of, I have a select before the output data that defines these fields as FixedDecimal 30.10, I also have a formula tool checking to see if the field is numeric and I have also tried putting in a data cleansing tool and setting Null to 0 as well as removing letters and still it fails. 

Due to the massive amount of data I cant find the individual row thats causing the problem - that was why I thought using the formula tool to detect if it was not a number might throw something up but does not and anyway, my select has it as a fixed decimal so Alteryx should surely throw an error trying to convert a string to number before it gets anywhere near SQL!

 

Error: Output Data (81): DataWrap2OleDb::SendBatch: Microsoft SQL Server Native Client 11.0: The statement has been terminated.\01000 = 3621; Microsoft SQL Server Native Client 11.0: Arithmetic overflow error converting varchar to data type numeric.\22003 = 8115

Asteroid

I think I have fixed it - seems to be a misleading error, the issue is that the number is too big, rather than its a string!  I have changed the column in the DB to be larger and its now not erroring.

 

https://blogs.msdn.microsoft.com/sqlforum/2011/04/19/forum-faq-why-do-i-get-a-arithmetic-overflow-er...

Labels