community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Analytic App - Output with Errors

Hello

 

I'm trying to convert my current workflow into an analytic app to make it easier on my users. The workflow runs with errors due to the summarize tool, I have mapped multiple fields in my summarize tool to cover all possible scenarios though a real user will only have 1 or 2 fields present. To clarify, I am getting the error that the field is not contained in the record. When I run the workflow from Alteryx, I get these errors but my output file still generates via render, however when I run it as an app, I only get a screen with the errors and no output file. 

 

Is there a way to override this? 

 

Thanks

 

Amanda

 

Highlighted
Alteryx
Alteryx

Hi Amanda, have you tried running the app in Debug mode to test where the errors are occurring? You can do this by going to View>Interface Designer. A new window will pop up and along the left hand side there are four icons. The second one, which looks like a wand with +/- is called the Test View. You can choose parameters as a user would and then click Open Debug. The debug workflow will open in a new workflow and you can run that workflow with your new parameters. The top portion will show your replacements setup via the Interface tools, so you can make sure that all looks correct. Then you will notice that your Interface tools are all missing, but each tool that had an update action will be updated with the values that you chose in Test View. I would take a look at the summarize tool and make sure that everything has been set up update properly. When you are done you can close that debug window, go back to the app, make changes, and test with other values.

 

It may not be the end solution but it should help get your fix started! The debug mode is sometimes underutilized but so powerful for testing apps!

 

Cady

Labels