community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

Alteryx not Working when connected to VPN

Alteryx stopped working when connected to VPN.

 

The product simply failed to respond to any clicks when my machine is connected to VPN.  It wasn't an issue earlier, i upgraded to latest version a couple of weeks back and after that i started noticing this issue.

 

I tried downgrading but still the issue persists. Any fixes ?

 

 

Regards,

Naveen

Alteryx Partner

Hi Naveen,

 

It happens with my Alteryx from time to time as well, although I am not connected to VPN. Not sure VPN is the issue.

 

Remember that in Options>User Settings> Advanced you have Auto - saving options. You can access the files from File> Open auto -saved files.

 

Hope that helps.

Hi Suli,

 

Thanks for your reply.

 

My problem is that I cant even execute the job when on VPN. The program makes a db connection to extract some records, I either need to be on VPN or client network for the connection to be successful.

 

The job get froze and I cant click the run button when connected to VPN. I never had this issue before with Alteryx in the early versions

Bolide

This could be related to a NAT issue, I would try flushing your DNS after you connect to the VPN.  To do this, run this command:

 

ipconfig /flushdns

 

I'm not sure if Alteryx caches DNS records, so you may have to close/open it after flushing your DNS cache.  Hopefully this helps.

Hi adm510.

 

Thanks for your reply. I tried the solution but it doesn't seem to work.

 

I tried opening the product connecting to vpn when on client network and It works but doesn't work at all when on VPN but outside the office network

@naveenn08

Sounds like a network security issue. 

With Windows, some sources/systems can be locked down based on the location you are connecting from.

I run into this issue when certain Windows roles expire and need to be renewed by our IT Security team.

 

TLDR; ask your network security team to make sure you have the right permissions for connecting to those data sources via VPN.

Hi,

 

I'm able to connect and extract data through SQL developer when on VPN. Hence I don't think its an issue with source system network security. The issue is not just to source extract component . The whole product hangs when connected to VPN.

@naveenn08

You mentioned it hangs and freezes - does it ever unfreeze or does it go to a non-responding state?

Also, do you know if your machine has a proxy connection setting?

And if so, do you know how to clear it?

 

Alteryx Partner

Our gallery access was denied whenever I turned ON vpn,

interestingly with vpn turned OFF, everything works well.

Its a serious security issue for my client.

 

vpn.jpg

 

 

 

Alteryx Certified Partner
Alteryx Certified Partner
But in your image that's the public gallery, you'd expect to be able to connect to that on an insecure network else No one would be able to access it!

Wouldn't be the biggest surprise that when connected to a VPN the gallery is blocked but most companies would whitelist this as gallery.alteryx.com contains many useful resources!

Ben
Labels