community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Alteryx crashes while scheduling

Meteoroid

Hi

 

I am trying to schedule a workflow. I go to the "view schedules" option and connect to the controller supplied to me, and when I click on the plus sign and add a workflow, Alteryx crashes within a few seconds with the following message (translated):

 

Untreated Microsoft. NET Framework exception in AlteryxGui. exe 17112. just-in-time debugging error of the exception: Just-in-time debugging is not enabled for any installed debugger. In Visual Studio, Just-In-Time-Debugging can be activated via the following menu path:"Tools > Options > Debugging > Just-In-Time".

 

Any idea?

 

image 02.JPG

 

Alteryx Certified Partner
Alteryx Certified Partner

@kinan,

 

Crazy thought here....

 

IIF(contains([Field_1],"position"),regex_replace([Field_1],"(\d+),(\d+)",'$1.$2'),Field_1])

If you read your yxmd into another workflow as CSV with a \0 delimiter (set field length to be 9999999) and uncheck the first row contains field names.  You can update the XML and then output as a csv with \0 as delimiter (you can name it with a yxmd extension).

 

Try updating the XML this way and see if it still crashes.

 

What you are doing is replacing all coordinates within the XML for tool positioning with dots instead of commas.  I administer a server that uses US standards, but it receives workflows from users around the world.  We've seen issues with containers and workflows saved to the gallery.  I only offer that maybe this localization bug has an impact on scheduling.

 

Cheers,

Mark

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Meteoroid

Hey @MarqueeCrew

 

Thank you for the response. I am not sure I understand what I should do. I have imported the workflow into another as CSV as you said, and here is a snippet:

 

image 03.JPG

 

If I scroll down some more, I see a different set of positions. Below is a sample; basically for every ToolID there is a position, but they are separated by a space instead of a comma.

 

4 <Node ToolID="1">
5 <GuiSettings Plugin="AlteryxBasePluginsGui.TextInput.TextInput">
6 <Position x="78" y="54" />
7 </GuiSettings>

 

28 <Node ToolID="2">
29 <GuiSettings Plugin="AlteryxConnectorGui.Download.Download">
30 <Position x="198" y="54" />
31 </GuiSettings>

 

67 <Node ToolID="3">
68 <GuiSettings Plugin="AlteryxGuiToolkit.TextBox.TextBox">
69 <Position x="54" y="114" width="108" height="48" />
70 </GuiSettings>

 

87 <Node ToolID="4">
88 <GuiSettings Plugin="AlteryxGuiToolkit.TextBox.TextBox">
89 <Position x="174" y="114" width="108" height="48" />
90 </GuiSettings>

 

Many thanks.

Kinan

Moderator
Moderator

Hi @kinan,

 

Sorry to hear that you are experiencing these crashes - we have a fix that addresses this issue that we are currently testing and expect to be released soon. I will update this post once it is available.

 

 

Sophia Fraticelli
Customer Support Engineer
Alteryx, Inc.
Meteoroid

Thanks @SophiaF. Is there any workaround I can do? Our other alteryx user is also experiencing the same issue, so I don't think a re-install would work. At the moment we are both on a trial license that is expiring soon as we are assessing the tool before purchase, and an issue like this is worrisome. 

Moderator
Moderator

@kinan - I will PM you shortly with additional details

Sophia Fraticelli
Customer Support Engineer
Alteryx, Inc.
Moderator
Moderator

@kinan (and for others who are experiencing this issue) - the patch for this has been released and can be downloaded from http://downloads.alteryx.com/Latest.htm

Sophia Fraticelli
Customer Support Engineer
Alteryx, Inc.
Meteoroid

Hi @SophiaF

 

Thank you for the quick fix. The application does not crash now. That said, whenever I go to the scheduler, the resolution of the application window changes and the fonts and icons become a lot smaller. It can be resolved by restarting the applicaiton but wanted to raise this issue for your team to fix. 

 

Other than that, I am unable to reach the controller. I have added the controller fine but when I select the workflow to upload, I get an error message from the server. Translated from German: A connection attempt has failed, because the remote station did not respond correctly after a certain period of time, or the established connection was faulty, because the connected host did not react (10060).

 

Is this something I have to raise with our IT to look into?

 

Thanks again!

Moderator
Moderator

@kinan - thank you for the update. I haven't been able to replicate on my end, but I will do some more testing and reach out. 

 

For the server issue - are you able to ping the server machine? You will need port 80 open (or 443 if using SSL). I would also check to see if your Server Admin has set the port to run on a different port just in case. This error also pops up around firewall issues on the server, which your IT can investigate.

Sophia Fraticelli
Customer Support Engineer
Alteryx, Inc.
Labels