community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Alteryx Running Long SQL in the Backround

Meteoroid

Hi, 

 

I am currently facing an issue where My Alteryx designer automatically runs a long SQL query when i just connect to a DB from my workflow. My IT team frequently email me saying i am running Long SQL(Which i am not!) and is affecting the DB health. However, when i close Alteryx designer the problem resolves.

 

Please advice.  

 

Thank you 

Pulsar

Hi @gajendsu

 

Check out this thread especially the last post from MikeSP.  it has to do with the query being run in the background so that alteryx can refresh the meta data.  

 

Dan

Alteryx Partner

You can stop this behavior a few ways, 

 

Can you take a screenshot of your configuration window please?

 

It also may be that you can switch it from lets say something inefficient such as oledb to odbc,.

 

Thanks!

Meteoroid

Thanks very much @daniland. I will look to disable the Auto configure and see if that helps! 

 

 

Meteoroid

Hi @The_Data_loop,

 

Attached my workflow configuration for your reference. It is using odbc drive already.  I am not sure what is causing this issue. 

 

Here is the Full SQL that Alteryx runs in the backround affecting my DB health 

create procedure sys.sp_datatype_info_100  
(
@data_type int = 0,
@ODBCVer tinyint = 2
)
as
declare @mintype int
declare @maxtype int

set @ODBCVer = isnull(@ODBCVer, 2)
if @ODBCVer < 3 -- includes ODBC 1.0 as well
set @ODBCVer = 2
else
set @ODBCVer = 3

if @data_type = 0
begin
select @mintype = -32768
select @maxtype = 32767
end
else
begin
select @mintype = @data_type
select @maxtype = @data_type
end

select
TYPE_NAME = v.TYPE_NAME,
DATA_TYPE = v.DATA_TYPE,
PRECISION = v.PRECISION,
LITERAL_PREFIX = v.LITERAL_PREFIX,
LITERAL_SUFFIX = v.LITERAL_SUFFIX,
CREATE_PARAMS = v.CREATE_PARAMS,
NULLABLE = v.NULLABLE,
CASE_SENSITIVE = v.CASE_SENSITIVE,
SEARCHABLE = v.SEARCHABLE,
UNSIGNED_ATTRIBUTE = v.UNSIGNED_ATTRIBUTE,
MONEY = v.MONEY,
AUTO_INCREMENT = v.AUTO_INCREMENT,
LOCAL_TYPE_NAME = v.LOCAL_TYPE_NAME,
MINIMUM_SCALE = v.MINIMUM_SCALE,
MAXIMUM_SCALE = v.MAXIMUM_SCALE,
SQL_DATA_TYPE = v.SQL_DATA_TYPE,
SQL_DATETIME_SUB = v.SQL_DATETIME_SUB,
NUM_PREC_RADIX = v.NUM_PREC_RADIX,
INTERVAL_PRECISION = v.INTERVAL_PRECISION,
USERTYPE = v.USERTYPE

from
sys.spt_datatype_info_view v

where
v.DATA_TYPE between @mintype and @maxtype and
v.ODBCVer = @ODBCVer

order by 2, 12, 11, 20

 

 

Highlighted
Alteryx Partner

this should get you where you need to be!

 

"Under Options->User Settings->Edit User Settings there is an option in the "Advanced" tab called "Disable Auto Configure".  If you check that off it will prevent your PRESQL or POSTSQL from running."

 

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/How-to-prevent-Pre-amp-or-Post-SQL-to-...

 

 

 

Meteoroid

Thanks, i have checked the Auto Configure and it certainly did reduce the SQL running frequently but it hasn't completely stopped i am afraid. My colleague did not check the Auto Configure and apparently our IT team found no long queries from my colleague. 

 

 

Is this anything to do with SQL drivers version? I have SQL driver version 11( SQL 2014)  and my colleague is running on  SQL 2008. 

 

I have also attached my driver configuration which allows to create temp stored procedure for prepared SQL , may be this is causing the issue? 

 

It is a very Strange behavior coming just out of my Alteryx designer. 

Labels