Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here

Alteryx Excel Output creating problems in PivotTable

Highlighted
5 - Atom

Hi All,

 

I recently created a simple Alteryx workflow to parse an excel file with 56000 rows into separate worksheets based on a number of filters I created. This worked smoothly, and I ended up with 12+ excel files based on my filters, the final file being all those rows that did not match any of the criteria of my filters.

 

In this final file, which has 24,000 rows, I am doing some additional analysis in Excel. I have been trying to create a number of pivot tables, and this is where I run into some issues.

 

1. I click create pivot table

2. I add the data to a data model

3. In my new pivot table, I create a measure based on the data from my Alteryx output and confirm the formula is correct.

4. When I try to add the measure to the values section of the pivot table, it doesn't work....

5. When I create a measure based on data I have manually added to my worksheet (i.e. data that is not sourced from the Alteryx output), this measure can be added to the values section of the pivot table.

 

I realize this is possibly an Excel issue, however because the measures work with manually created data versus not working with output from Alteryx, I wanted to see if anyone here has faced a similar issue.

 

I didn't add my files as they contain sensitive data, however if that would be helpful I can create a redacted version, just let me know.

 

Appreciate any advice!

Highlighted
14 - Magnetar

Hi @emk2034,

 

a redacted version would be super helpful! But let me do a guess here: The data has most likely the wrong data type and that's the reason the Pivot table isn't able to pick up the values. I would double check the data types before you write it into Excel. Make sure all numbers have a numeric data type and are not strings.

 

 

Best

Alex

Labels