Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Alteryx Crashes with any Pop-Up Window


Hello all!



Not 100% sure if this is the right place to post this, but I've been having an issue with Alteryx ever since I started using it, but I haven't seeked help until now.


Essentially, Alteryx crashes when the 'Getting Started' window pops up, when clicking the 'Add or Remove Tools' plus sign to bring up the tool configuration pallette, AND when I even so much as touch the 'Block Until Done' tool.


As far as I know, the first two issues involve a secondary screen popping up (this is probably the issue), so I just disabled the start-up screen and don't touch the tool configuration. I'm not sure what the options look like for the block tool (whether it has a pop-up or not), but all I know is that I really would like more access to my tools. Haha.



Things I've tried:

Installing a copy over Alteryx as a 'repair'

Uninstalling and re-installing a fresh copy

Running in various compatibility modes


Things I haven't tried:

Deleting all source files that Alteryx uses (I noticed that on a new install it will save my configurations)

Using an older version

Throwing my computer in the trash



If you or anyone else has had this issue, please let me know! I would love to fix this problem.




Hi @richarty,


Please reach out to and one of our Customer Support Engineers will be happy to assist!

Sophia Fraticelli
Premium Support Advisor
Alteryx, Inc.

Will do! I'll update this thread with the ultimate solution once I get it figured out.

Alteryx Certified Partner

I've had this same problem for the past 3-4 weeks..


Things it crashes on:


  • Viewing a 'Browse Tool' that's connected to the report output of a Linear Regression tool.
  • Adding a Block Until Done tool

I've found Alteryx to be super reliable for more than a year, so it's strange that the bug has recently appeared. It's making certain kinds of dev impossible (sometimes you -need- a block until done tool!)



Alteryx Certified Partner

Richarty, out of interest, try resetting your Windows sockets by typing 'netsh winsock reset' into a Windows cmd prompt (run as administrator).


I tried a lot of things and managed to fix my issue. Not sure if the above is what did it, but after doing this, the issue is fixed.


@NickDuncan, I don't know how you discovered this, but this is exactly what fixed it! I am estatic.


Thanks a bunch! Hopefully this will point the Alteryx development team to a good general direction on preventing this issue in future builds.