Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here

Alteryx Azure Data Lake tools not installing

Highlighted
5 - Atom

I just downloaded the Azure Data Lake tools from https://gallery.alteryx.com/#!app/Azure-Data-Lake-Tools/5b1fffbd8a93371030bcfedc

and the installation should be straightforward with just clicking the azure_data_lake_v1.0.0.yxi file but i get no error but it just says it is installing, when i click the ok button it just starts the installation over again.

 

Please help me on how to do this!

Highlighted
Alteryx
Alteryx

Hi @Liam,

 

Thank you for reaching out on Community.  We are actively tracking this issue right now.  Could you please send an email to Support@alteryx.com and we can help get you squared away.

 

Thanks!

 

Kyle Bradley | Customer Support Engineer   

Highlighted
5 - Atom

Hi HyleB

 

The problem is resolved.

 

Thanks

Highlighted
5 - Atom

Hi 

 

How did you resolve this - I am having problems installing this. 

 

As user it say s

downloads python package

says it found PIP-9.0.1

uninstalls this 

Installing python dependencies

Fails with An error occured during installation of the python tool. Exception: 

 

I think this is for the input tool. I then get a repeat as it tries to install the output tool.

 

Any help appreciated

Thanks

 

 

Highlighted
Alteryx Certified Partner

Hi All

 

I have the same issue. What's the resolution for this?

 

Best

Mesiya

Highlighted
6 - Meteoroid

I tried downloading

 

  1. Download the ADLS tool
    1. https://gallery.alteryx.com/#!app/Azure-Data-Lake-Tools/5b1fffbd8a93371030bcfedc

and then there was nothing to "execute" once I got the files locally (folder was 'azure_data_lake_v1.0.2'). Directions on this are terrible.

 

I tried doing it from the gallery....

 

  1. Log into the Alteryx Gallery
    1. File>Open Workflow>Alteryx Galley  (requires uid/pwd)
  2. Search for “AZURE”
  3. Choose Azure data lake Tools - but I cannot because its greyed out: “This workflow cannot be opened because the owner has disabled download”
Highlighted
6 - Meteoroid
My problem was that I was not using administrative privileges when installing the software. -russ

Russ Harris
Analytics Manager
Mars/Wrigley Confections
Highlighted

I had some problems installing the connector too. After a little back and forth with the Alteryx support desk, I was given a good idea on how to make this happen.

 

  • Change the extension to the package to .zip
  • Unzip everything into a directory
  • Look for and change requirements.txt so that all versions are >= rather than ==

ex. azure_data_lake_input_v1.0.2/requirements.txt:

azure-common==1.1.14 became azure-common>=1.1.14

 

  • Zip up the contents and change the extension back to .yxi
  • Install

Hopefully they'll roll out a new version so that it the libraries it depends on uses a minimum version or higher rather than a strict version number

 

Peter.

Highlighted
6 - Meteoroid

Thanks for this.

 

I tried the suggestion (find + replace == with >= in both requirements.txt) but not getting another error:

 

Tool Installer Error: Unable to find a configuration file

Highlighted

If I have to guess, you used the Windows to extract the .zip, edited the files, then zipped it back up. That might miss something. I used 7Zip to open the .zip file, edited it, saved it all and installed it.

Labels