community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Alteryx 2019.1 Issue - Salesforce API calls return SOAP errors

Highlighted
Atom

We upgraded our environment from 2018.3 to 2019.1. Post upgrade, existing salesforce API call jobs are failing with SOAP API errors. Did anyone face these issue. These jobs used to run just fine in 2018. 3 version. 

 

Error: ToolID:X Unable to reach SOAP API(Check URL).

 

If anyone has a solution, please do post it here. 

 

Thanks!

Alteryx
Alteryx

This is usually a proxy error.  Check the Salesforce KB for suggestions on a fix.  

 

Scott Jones
Strategic Sales Engineer
Alteryx, Inc.

I found your post and several of us who upgraded to 2019.1 have this exact same problem.  Others who remain on 2018.3.4 are able to connect just fine.

I tried configuring the Alteryx Proxy settings as we have a PAC file controlling proxy settings as found in IE (and shared with Chrome, Firefox, etc), thinking that whatever settings I may have made in 2018.3.4 were lost as part of the upgrade.

So far, nothing has worked.

I'll check the Salesforce KB as suggested.

 

In the meantime, did you find a solution?

 

 

Hi.  You mention that the issue is likely due to a proxy setting.  Since nothing has changed in my installation except upgrading from 2018.x to 2019.1, then either the configuration from 2018.x was not preserved during the upgrade process, or something else is amiss.  We have a PAC file to control proxy configuration, so I'm not inclined to alter this only to have it overwritten during the next software patch cycle.  I've gone through the limited number of proxy setting options but haven't hit on a solution.  I'm not looking to downgrade to 2018.x, yet other 2018.x users don't have this issue.

 

Any other thoughts come to mind?  Thanks.

Atom

Hi,

 

Our issue was with Salesforce API call which was didn't work. However the fix was to use "Salesforce Input Tool" which will no automatically install with designer. Reference: https://help.alteryx.com/2018.3/Salesforce-Input.htm . After configuring it worked. 

 

We had to rollback to 2018.3 ( previous version) because there is a bug with 2019.1 that we found. 

 

Details: Proxy issues with any API calls with internal or external apps. ( ex.. Salesforce, etc..) . There is no timeline defined on the fix yet.

 

Thanks,

Harish

Hi Harish.

I'm using Salesforce Input Tool -- not SF API -- with 2019.1, and this does not work.  [I installed SF Starter Kit when installing 2019.1]

 

Do I understand correctly that you're able to get SF Input Tool with 2019.1 to work ok?

Might you have the Issue number for reference?  I'd like to know when this fix is available.

 

I may rollback to 2018.3 because all was working fine until upgrading to 2019.1.

 

Regards,
Bruce

Asteroid

Following...Similar errors after upgrading to 19.1 from 18.2 "API Error: Gateway Timeout." Working our way through the suggestions w/ no luck. Downgrading is not an option for us. 

Labels