community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Alteryx 2018.3 - Salesforce Input Connector Error

Hi,

 

I am using the latest version Salesforce input v4.0.0 connector in my Alteryx designer (v2018.3). I am able to connect successfully to my sandbox environment and validate the SOQL query. Screenshot below.

However, when I try to run the workflow the data is not read from the input tool and I get the error message provided below. The prior version of salesforce input connector used to work correctly and it used URL as one of the input fields which is not an input in the latest version. Kindly assist.

Capture.JPGScreeshot of successful connection to Salesforce object

 

Error: Salesforce Input (1): HTTPSConnectionPool(host='test.salesforce.com', port=443): Max retries exceeded with url: /services/oauth2/token (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x0000000005533518>: Failed to establish a new connection: [WinError 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond',))

Alteryx
Alteryx

 Hi Bharatpai11;

 

I am working on doing some digging into this, but I did want to provide you with a short term solution, in case this item is blocking you from something critical.

 

If you right click on your tool bar in Alteryx Designer, there is an option to "Show Deprecated Tools" - if you choose this, the old SFDC connector is still available under the Connectors tab, this would allow you to continue using things as you used to.

 

That said, I am digging into what might be causing this issue with a few other people and will circle back when I have something.

image.png

Note: In my screenshot it reads "Hide Deprecated Tools" because I already have them being shown :)

 

Cheers!

Zak

 

 

 

 

Atom

I also have problems with new Input Tool

Getting this error, although check 

 

Error: Salesforce Input (13): Traceback (most recent call last):
File "main.py", line 160, in pi_push_all_records
File "C:\Users\[username]\AppData\Roaming\Alteryx\Engine\../Tools\SalesforceInput_v4.0.0\engine\sf_queries.py", line 74, in process_query
loop.run_until_complete(retrieve_query_json(self, query_endpoint, header))
File "C:\Program Files\Alteryx\bin\Miniconda3\Lib\asyncio\base_events.py", line 466, in run_until_complete
return future.result()
File "C:\Users\[username]\AppData\Roaming\Alteryx\Engine\../Tools\SalesforceInput_v4.0.0\engine\sf_queries.py", line 42, in retrieve_query_json
if self.json_parse == 'True' and self.query_type == 'customQuery' and self.parse_query_flag == 'output_json':
AttributeError: 'AyxPlugin' object has no attribute 'parse_query_flag'

Atom

I am using a filter for CreatedDate in my where clause and it is messing up my query.

Highlighted
Atom

Did you find a fix for this? I am getting the same error when using a CreatedDate in my WHERE clause.

Atom

Nope, still the same issue

Atom

It looks like it is a problem parsing the JSON query. When I use last_week instead of a specific time or last_n_days on my WHERE clause I can successfully pull data down, but the data are in the wrong fields - so the JSON parse is still failing, just failing slightly less.

Hi,

 

The Salesforce input/output connections (deprecated tools) were working perfectly in 2018.3 version of Alteryx.

But I updated to 2018.4 and none of the salesforce connectors are working (including deprecated tools.

Is there any fix being applied to make sure the connectors are working in all future versions of Alteryx?

 

Regards,

Bharat

I am also getting this error.  Any update?  I am new to Alteryx and this is the first time I've downloaded it so I don't have deprecated tools.

Labels