community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Alteryx 11 Performance Issues

Asteroid

Just to add to the above. I def don't have 4 core processors and am using a virtual machine which is based in HK. I am using the 64bit version of the software which my machine supports. 

Meteor
The issue I'm having occurs whenever I use the in-DB input connection.

If I just use a standard (green) Input Data tool, everything seems to work well.
Asteroid

I am just using the standard input tool in the default favourites

Bolide

Define virtual machine. What's the setup?

Alteryx Everything, Leave no one behind.
Quasar
Quasar

Why do we think Machine specs would matter?  If 10.X has worked perfectly fine for 2 years, and all of a sudden 11.X has these issues, I don't think the issue would be with the machine.  So I'm just curious as to why the machine specs would all of a sudden matter.

Asteroid

This is my machine credentials

 

Manufacturer: VMware, Inc.
Model: VMware Virtual Platform
Serial Number: VMware-42 3c 1f d9 51 cd 82 4b-cb 31 e0 87 72 d1 37 25
BIOS: 6.00
OS: Windows 7 Enterprise AMD64
Service Pack: Service Pack 1
BAND Build: 7.33 b1
BAND BCU: 2016.01
CPU: Intel(R) Xeon(R)E5-2690 0 @ 2.90GHz
Threads: 2
Memory Size: 8 GB
Hard Drive Size: 99 GB
Free Space: 7 GB
Bitlocker Status: UNKNOWN
AV DAT DATE: 2017/09/25
IE Version: 11.00.9600.16428
.NET Version: 4.5.51209-2
PowerShell: 4.0
Time Zone: (UTC+10:00) Canberra, Melbourne, Sydney
Last Reboot: 2017-09-28 07:25:11.375
Reboot Needed: FALSE
OSD CACHE: 0

@mbarone

I agree with you to an extent.  It shouldn't matter when you go from 10.X to 11.X if 10.x was working.

There is a bug in 11.x which I have only been able to reproduce on my laptop due to its low grade hardware specs.  That's the only reason I asked.  Just wanted to see if the specs were similar, infering that the cause could have been similar.

Highlighted

@DamienMinter 

Do you have the ability to change any of the specs on the virtual machine (such as allocate more RAM, disk space, or CPU cores)?

 

I'd start by wiping this machine and starting over.  Make sure you get at least 4 cores (8 threads), 16 GB of RAM, and at least 40 GB of free disk space (amount left after OS is installed).

Leave all of the Alteryx settings as default.

Quasar
Quasar

Interesting.  

 

In that case, here's my machine's specs - it's a virtual machine with 4 cores:

Specs.jpg

Asteroid

@patrick_mcauliffe

 

Lol, no. I have what they call a Tier 2 spec computer (which is apparently better than a tier 3 so should count myself lucky!!!) - Tried to apply for a Tier 1 Spec at some point last year as was having a few issues, apparently it costs $25 dollars extra per month. Had my managers, managers, manager sign off on it, but due to tech protocol they had to mention the performance of this for a couple weeks, which was done by an offshore team and our local tech guys couldn't even get them to send over the logs. Thats as far as it got. But have to say thats its better than the pieces of cr*p I have uses at other organisations.

 

I am still doing some proof of concept stuff atm, but if there this evolves into a business requirement then could be worth asking the question again. 

 

I have managed to work with it ok for now. If I allow it time to catch up when I make changes, allocate 4 to 5 GB Ram to run it the first time and then drop it back down to 2, it is usually ok. Just takes a little longer than I hoped to get stuff done. When the workflow runs usually only takes a couple seconds. fingers crossed It is I have enough power to scale out a little bit more.

Labels