community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Alteryx 11 Performance Issues

Meteor
I recently upgraded to 11.x. Turning off data profiling doesn’t seem to help anymore.

Sent from my iPhone
Asteroid

Hi, I am using Alteryx 11 on a demo licence to try and do a proof of concept for work. I am having this same issue and it is lagging each time I update something. I only have the deom licence for a little while and this is really impacting my ability to get something out for management in time. The original post was made back in February, so I assume there is a fix? - I have version 11.0.6.28907 installed on my machine. Do I need to get our tech team to install a different version?

.

Highlighted
@DamienMinter
I would recommend updating to 11.3 or 11.5 and turning off data profiling in the user settings.
Quasar
Quasar
I still had the issue a few weeks ago when I tried the latest update. I reverted back again to 10.6.

I'll try again with the next update. My rep gave me some steps to collect logs when I try it again.
Asteroid

I just tried turning of the data profiling in the user setting and have noticed some improvement. Its seems weird to me that they would release to production with such an obvious performance issue.

Quasar
Quasar
Yes, turning off data profiling didn't help me too much either.
Asteroid

Yeah, there seems to be some serious issues with 11.0 (not sure if these have been fixed in 11.3 or 11.5 and would be interested to know) I don't have the lagging anymore, but a lot of times my workflow doesn't work (times out) and I have to click on each part of it individually to get it to go again. Also, never works if I try to run while having the mouse selected on a anything other than input or output. 

Alteryx Alumni (Retired)

Hi @DamienMinter,

 

I'm sorry to hear that you are seeing performance issues.  Can you describe the performance lag you are experiencing?  What data connections do you have in your workflow?   If you start a brand new workflow and connect to data, do you see the same slowness?

 

Thanks,
Ben

@DamienMinter

Can you post your machine specs?

Processor series and number of cores (Ex. Intel i7 - 4 cores)

RAM (Ex. 32 GB)

Local drive type (Hard Drive or Solid State Drive)

Asteroid

Hi, Apologies for the delayed response, I have been trying to do some testing to figure out what is going on. I have been trying to fit this around my day job so always easy. I don't have the exact specs but I have 8GB of Ram and am using Windows 7, not sure of the processor as don't have it to hand. I am pretty sure it is something to do with memory allocation though as I have been messing around with the settings on the resource allocation for joins. The behaviour is very strange though, ie I can have a very simple workflow that works perfectly and I make a small change and it will stop working. I can reserve more memory and then it will work (say going from 2MB to 3MB). Then I can change it back to 2MB and it work perfectly. I then make a small change and it not work again. Sometimes I have to reserve up to 5MB to get this to work, and then sometimes it stops working with 5 and I have to reduce this to 0.5MB. I am struggling to find any consistency and not sure what is exactly is causing this to happen. I have been speaking to a Alteryx rep, and we kind thought it must be doing something to do with my computers memory competing against other resources, I think this might have something to do with it, but if I monitor the system usage and don't touch anything apart from Alteryx the workflow stop working. I don't see any significant change in my system memory. We are talking very simple workflows - like 1 input with 400 lines, a select tool, filter tool and transpose tool and viewer. When it does work it runs in 0.6 seconds, but then just stops.

 

Also, also having issues if I change something upstream ie rename something in the select, this is not getting picked up in the transpose tool which is also meaning I am spending more time replacing the tools than building my workflow. Just to confirm this is not what is causing my flow to stop working, is can be as small as moving a tool 3 to 4 pixels or even run the first time then not run the second time. 

 

Would love some input around this as it killing me timewise

Labels