community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Alteryx 11.5 Database connect Error

we are trying to connect 64bit oracle database from INPUT Data tool/IN Database tool and we get error -

 
Error: Connect In-DB (2): OCILogon2 Error: ORA-12154: TNS:could not resolve the connect identifier specified

 

note -Oracle 10g & 11g drivers are available in the system but still we get above error.  Also tnsnames.ora file has all the needed entries of the database.

Highlighted
Alteryx Certified Partner

This could be caused by a number of issues.  First, I'd try to manually type in the connection string using this syntax:

oci:username/password@hostname:port/SERVICENAME

Capture.PNG

If this works then there's an issue with the tnsnames.ora file.  If there are other files in the folder containing the tnsnames.ora file, that could throw things off.

 

If that doesn't work then there's likely an issue with the driver.  Not sure, but having the two Oracle drivers on your machine could be throwing things off too.  Make sure the path is set to the correct driver in your environment variables (i.e. put the correct path as the first entry in the path see link to instructions below).

https://www.computerhope.com/issues/ch000549.htm 

 

Hope this helps.

Atom

Amazing! Tried your way and it worked perfectly. 

 

I noticed that when I entered the connection details in Alteryx's window, I put Service Name as TNS server name. It seems TNS server name is really the host name.

Labels