Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here
SOLVED

Add Macro to toolbar

Highlighted
7 - Meteor

Can anyone tell me how to add a macro to a toolbar? Specifically, I have downloaded and run the Model Comparison macro. It belongs in the predictive toolbar, but I do not know how to install it there and it doesn't show up in searches, even though I am looking at it in the workflow. Any help would be appreciated.

Highlighted
Alteryx
Alteryx

If you go to Options->User Settings->Edit User Settings and then the macro tab you can add additional locations for Alteryx to load macros to the tool bar from.

Adam Riley
Principal Software Engineer
Tech Lead Core Engines, Alteryx
Highlighted
7 - Meteor

Thanks, AdamR. That did it!

Highlighted
Alteryx Partner

Hi, I'm having a bear of a time adding a custom location to my macros toolbar.

Here's the deal:

I'm developing macros and then deploying them in a shared, network location. I'll call this Production/, whereas the other locations are 'dev'.

I've added both the Production location and the Dev location to my macros section in user settings. I've even gone so far as to make the Production location the default.

Production/macroAv961.yxmc does not show up in my Preparation area. 

Dev/MacroAv2.yxmc shows up there just fine.

Both areas are loaded in my macros section. The macros have different metadata, filenames, icons, and everything. But I cannot get the macro to show up and I cannot search for it nor deploy it in a workflow. 

This is extremely frustrating. Can anyone help?

Highlighted
Alteryx Partner

I solved my own problem. Here's what I did:

The Root Tool Name was incorrectly attributed to the 'preparation' area. I updated that.

I updated the Category Name to 'custom macro'. 

I clicked the + in the toolbars to add 'custom macro' to the set of categories I have.

I checked the macro (it was unchecked) in there so I could see it.

I then updated the Category Name back to 'Preparation', where I wanted it originally. 

The trick was to turn the thing on. For whatever reason, it was hidden. 

Labels