Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Access Database tables not refreshing

Highlighted
Meteor

I am trying to pull in some data from Access 2003 databases using Input Data. When I select the database and try to choose the tables to pull in, I have been getting a run time error. I then tried to create a new access database and just import in the tables I needed to make the new database smaller, and run the Input Data off of the new Access database. When doing this, I no longer get an error message but there are no tables shown. There is a note that says Table List is Cached. Last Refresh 06/09/2014 11:00AM. When I click the refresh button, nothing happens. It is not refreshing, no tables are shown, and the note still says the same thing. 

Alteryx Certified Partner
Alteryx Certified Partner

@ShannonH,

 

Advice from the peanut gallery:

  • Is your computer turned on (just kidding)?
  • You might want to delete the input tool and put a fresh tool on the canvas.
  • If you still can't see the tables, can you see them from access?

I would make sure that access itself is NOT Running when trying to read the mdb file.  I've worked with clients reading some fairly large tables and things run smoothly.  Hopefully things clear up quickly for you.  You can reach out to support@alteryx.com or if you're flexible you can PM me with your email and maybe I can webex with you to help.

 

Cheers,

Mark

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Highlighted
Meteor
Yes, the tables are all in the actual database. I have created new
workflows as well as restarted my system. I have created workflows that
worked with access tables before but this is my first time trying it on a
new computer so I'm not sure if there is some sort of compatibility issue?
I would love to webex! I'll shoot you a PM.
Highlighted
Meteor

So I was actually able to figure it out enough to make things work. It looks like the table I was trying to bring in was linked to a database that was just really huge, which resulted in the error. I copied the tables over into a new access database without the link and I was able to get them to work. 

It worked with this same database before, but maybe it juuust hit the threshold with added data.

 

I'm pleased. :)

Labels