We're excited to announce that we'll be partnering with Credly starting October 19th - see what this means and read the announcement blog here!

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

AMP engine summarize errors

jtr_denver
5 - Atom

This is more of a warning, and not a question, but I just wasted a good part of the day trying to track down an issue, only to realize my issue was the same bug I reported back in May. This bug has been been accepted as a defect by Alteryx (but frustratingly assigned a low priority.) 

 

The problem is that you may get inconsistent results with the Summary tool depending on if AMP is on vs. AMP being off. 

 

Image 2.png

 

This screenshot above is a good example. The top row represents my workflow outputs when AMP is OFF (header names changed for confidentiality reasons). The bottom row represents the same exact same workflow / data, with the only difference being AMP was ON. I had been cheerily working with the bottom row, when the top row better represents what is truly happening. Ouch.

 

When I submitted my ticket, I included a version of the attached workflow. Feel free to try it yourself. I just tested using the latest version of Designer, and the problem still exists. 

 

All that being said, please use caution, and double check your outputs to ensure they line up with your expectations if you are using the AMP engine. I've been working with bad data, and reporting to my executive team that same bad data. I would hate for others to be in that same boat. 

 

Alteryx, if you're listening, please fix this. 

 

 

4 REPLIES 4
MarqueeCrew
19 - Altair
19 - Altair

@jtr_denver ,

 

sage advice. Thanks for sharing. 

 

 cheers,

 

 mark

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Please Subscribe to my youTube channel.
danilang
18 - Pollux
18 - Pollux

Hi @jtr_denver 

 

It looks like the rabbit hole goes deeper with version related issues as well.  I'm on 2021.1.4.26400 and I see no differences between any of Amp-Int64, Amp-String, Amp-Double and non-Amp. All of the output files are included in the attached package.

 

Dan 

TonyaS
Alteryx
Alteryx

@jtr_denver 

Thank you for the post. I found the original issue and it is already in progress. @danilang thank you for the yxzp I will add it to the issue with your notes. 

If we are able to get this fixed in time for the 2021.4 Release I will update here to let you all know. 

Tonya Smith
Sr. Technical Product Manager, Alteryx Engines
TonyaS
Alteryx
Alteryx

This will be fixed with the 2021.4 Release version. 

Tonya Smith
Sr. Technical Product Manager, Alteryx Engines
Labels