Alteryx Designer Desktop Knowledge Base

Definitive answers from Designer Desktop experts.

Visually Compare Workflow Versions (App)

Alteryx Alumni (Retired)

Hi All,

A product idearecently introducedthe ability to compare workflows using the command line from Windows.

I thought it would be good to turn this idea into a more GUI friendly v11.3 Alteryx Analytic App.

Please see attached and enjoy!

Kind regards,


***Update 8/1/18***

If you find after entering in the workflow locations in the Analytic app, then nothing happens and you just get a completed box appear.

In Alteryx Designer go into User settings (options>user settings>edit user settings). Make sure 'Open Alteryx files as new workflow tabs in the same Designer window' is deselected.



Update 26/08/2018

By popular demand and saving users from having to edit the workflow app.

Added in the quotes around the filenames and repackaged

10 - Fireball

Hi ShaanM,

I did run it as an analytical app, the other way is just a workflow. I entered in both location and but it didn't open a new designer session.

I'm assuming it's because you aren't including quotes to take in to consideration folders with spaces in them.

But that would be my guess.

10 - Fireball

Hi @ShaanM


I tried running the app but it only resulted in no output after comparing two versions.. any suggestions?

Alteryx Alumni (Retired)

Hi @levell_x_dunn


When you run the app, the app itself produces no output.


You need run it as an Analytic app by selecting the magic wand icon next to the run button.


Enter in the location of your: C:\Program Files\Alteryx\bin\AlteryxGui.exe and also your workflows.


When you click finish it will open up a new Alteryx Designer session and you will see your workflows side by side - something like this:



14 - Magnetar


Does this tool work with the "User" installation of Alteryx Designer?

I have version 11.5 installed as a "User" Installation, and when i run the /diff command, either using the application or the command line, it does not seem to do anything.





I managed to get this to work from the command line by adding quotes around my filenames and doing a CD to the "User" install folder beforehand.  There were no spaces in my file paths or file names, so i'm not sure why the app wouldn't work.

Alteryx Alumni (Retired)



I managed to get the App working which will become handy!


In order to get @ShaanM's App working, I had to do the two following things.


1. Added double quote as @Claje has indicated: (highlighted in blue below after selecting the "Run Command" Icon)



2. Added Path in my Environmental Variables as the following: C:\Program Files\Alteryx\bin\

You can find Path by clicking on the Windows icon > Control Panel > System and Security > System > Advanced System Settings > System Variables (Path)


Alteryx Alumni (Retired)

thanks @Claje and @JudyN


I have updated the post and added in a v2 change for the app, which includes your suggestion of quotes around file names which may affect some users.



5 - Atom

Hi @ShaanM,


Do you know of any way to get tabular/text results of the diff function? The visual piece is nice but I'd ideally like to be able to archive version changes.




Alteryx Alumni (Retired)



One way you might be able to do this is to read both workflow files in as XML.


Then to build a workflow to compare the two 'xml' inputs..


It will be a bit more involving but could work out quite nice. If i get time i will try something this week and message you how it looks



6 - Meteoroid

Just wanted to say I LOVE this app. Thanks!!

6 - Meteoroid

Never mind. Once I changed the user setting as suggested. It worked!


Hi Thank you for building up the Macro. When I run it as an app, the message I got a message referring to the memory size. However, it will work if I run it in the cmmd way. Any thoughts will be appreciated!

Error Message.png



6 - Meteoroid
Using this as an inspiration I built a more detailed app that also spits out a report using the underlying XML - grateful for feedback!
8 - Asteroid

@ShaanM, I changed the extensions in your V2 to use this against analytic app workflows (.yxwz). It produces the comparison workflow in Alteryx Design, but I get a Missing Macro message where there are embedded macros, specifically the following message "this workflow references macros [SheetFinder.yxmc ... SheetReader.yxmc] that are missing or inaccessible. Saving this workflow will permanently disable these tools". 


Anyway configuration I could change so I do not get this error message?

Alteryx Alumni (Retired)

@jdbartosh check the workflow dependencies across the workflow and macros used. It might need to clear orphaned tools or locations that are no longer present.
Options > Advanced options > workflow dependencies 

8 - Asteroid

My fault, rookie mistake, I was using a download from our Gallery. To anyone interested - this workflow will work on analytic app workflows with simply adjusting the extensions to ".yxwz". Thank you @ShaanM for putting this together! 

7 - Meteor

I am having trouble getting the workflow to work. I have the app setup and I put in to workflows but I just get a message after running that there is no output. I checked the settings and everything is correct. Does the output of the workflows matter?