Alteryx Designer Desktop Knowledge Base

Definitive answers from Designer Desktop experts.

Unable to find the dll: "OCI.dll"


Unable to find the dll: "OCI.dll"

Within Alteryx this error will be prompted due to a mismatch between 32/64 bit drivers and the Alteryx bit version. This error may also appear if you do not have the drivers installed.

One way to troubleshoot this is to find out what drivers you have installed!

You can use an input tool in the Alteryx Designer, go to Other Databases and select either ODBC/OleDB (64-bit) or 32-Bit Database Connections -> ODBC/OleDB. In the next pop out window it will populate with the available drivers for those connections. If you have no drivers in this pop out window this means you do not havethe correct drivers for 32 bit or 64 bit connection dependent upon which one you chose.


Links to drivers are available from within individual data source pages here. This will take you away from the Alteryx website and onto the driver provider’s pages. Please consult with your IT to find the correct drivers for your environment.

5 - Atom

I had the same issue while connecting to Oracle DB. Well it took me a while to resolve this issue. Please note that the below mentioned steps should be followed by those who doesn't have Oracle client on their PC. If you already have a client on your PC then you only need to set the environment variable.


Go to this URL and download Instant Client Package-Basic


Extract the zip file and save it on you PC like this:   C:\ORACLE\instantclient_12_2


Next step is to create environment variables locally


Right CLICK on My Computer > Properties > Advanced System Settings > Environment Variables 


Under System Variable create a new variable ORACLE_HOME and put the variable value as  C:\ORACLE\instantclient_12_2




Now edit the PATH system variable and input the oracle client path "C:\ORACLE\instantclient_12_2" at the end of other variable followed by a ";"




DONE ! Smiley Happy

10 - Fireball

Hi All,


Just reviving this thread as I'm coming across the exact same issue when using Alteryx Scheduler. Fortunately, I am able to connect into my Oracle database when running a workflow manually. The problem occurs when I am scheduling the workflow to Scheduler (local - not Alteryx Server). The Scheduler kicks in and tries to run the workflow but get the "unable to find the dll: OCI.dll" message below. 


I've performed all the steps that Jishnu explained above to no avail. 


System DSNs are all configured both on the 64-bit ODBC Administrator and Alteryx In-DB Connection Manager.


If anyone comes across this and has any suggestions or advice, would be greatly appreciated!

Alteryx Scheduler oci_dll error.PNGOracle_system_indb.PNG

Alteryx Alumni (Retired)

@williamchan If the workflow runs fine through the designer (aka manually) but fails through the scheduler (local), most likely is due to permissions, as the scheduler runs with the Local System account. Try going to your system settings > worker > Run As and enter your credentials there and try again.


Here is a post on the Run As : 

10 - Fireball

Hi Margarita, unfortunately adding the Run As creds prevents my workflow from being accessed by the system. When I run the workflow without "Run the Worker as a Different User" credentials on other Databases it seems to run properly, so I am going to leave out the credentials and try to see if  reinstalling the instant client and restarting the computer will work.

5 - Atom



I am reaching out to this thread because it seems to be focused on the same issue that I am currently having.


I have a workflow that I was having trouble connecting to Oracle. I am getting this error also.


I have a driver installed, and I was trying to use that. I've pointed all of the mentioned variables to my Oracle Client's home folder (network folder in the case of the TNS_ADMIN variable). I've added it to my systems list of ODBC drivers, but when trying to connect via the Oracle option, I don't see any avaialble connections, and when connecting through ODBC, I managed to get it to work once and saved that workflow, but when I reopened that workflow, the tool threw the "Unable to find the dll:"OCI.dll" error. 


I don't seem to have any issues running these quereis in SQL Developer, so I think the drivers and variables ar working fine. Hopefully someone can point out what I'm missing, or where I'm going wrong?



7 - Meteor

Nicole, don't know if this will help or not... 

I had a similar problem. I could build and run the workflow on my desktop designed but it horked on me when I tried to save it to the gallery.


The problem appeared to be ALL on the Alteryx Server side.

* I loaded the Oracle Client drivers, then made sure that the folder into which they were loaded was shared to the account on the Alteryx Server that was going to run it from the Gallery Scheduler. So I shared C:\Oracle (which had the path to the drivers) to that account

* I modified the system environment variables so that ORACLE_HOME pointed to that path, and in the PATH= I added the path to the \bin folder which had the OCI.dll

* I also added a TNSNAMES.ORA file to the Server that matched that of my desktop, to that the name I selected matched the server and service, etc. of the system (Alteryx Server) I'm requesting to run the workflow.


I slogged through it, and it finally worked. 

Hope this helps you or another Alteryxer who encounters this in the future.

5 - Atom

Hi - I'm having this exact same issue but it's happening when I try to run my workflows over a VPN connection.  In the office my workflows run just fine but remotely I get this error.  My Oracle connections are fine because even over VPN I can run them in SQL Developer with no issue.  Is it a path issue?  I tried adding my OCI.dll path to the environment variables but it didn't make any difference.  

5 - Atom

I am having this same issue.  Our ORACLE databases are 32-bit versus 64-bit.  I've set-up the server to run as a different user.  The ORACLE plug-ins live on a network drive address and the system/environmental variables seem to be pointing in the right direction. 


What is more interesting is that when I schedule a workflow that is using excel files in network file locations, there seems to be no issue running it.

8 - Asteroid

Hi All,


I am facing a similar issue and went thorugh the entire thread though I am unable to fix the issue. 


Basically there are two issues that I have:-

1) I am getting an error "Unknown variable Split" when I use Formula "ToString(Split,([Attendee Resolved Entity], "(" , 1))"

2) Unable to load dll.


With refards to the second error, I followed the steps that were mentioned by Jordan who started off this thread by going to All data sources in 32-bit connections and then clicked on ODBC, I get the attached screen. Can someone please guide what are the next steps I need to take.