Alteryx Designer Desktop Knowledge Base

Definitive answers from Designer Desktop experts.

The 'How to Guide' to the Salesforce Connector



The improvements in our salesforce connectors have been astronomical over the last year and now it is easier than ever to navigate the UI configuration screen and connect to your Salesforce Data.


From here in the Salesforce connector will refer to both the Salesforce Input and Salesforce Output


There are a few things you will need in order to use the salesforce macros

  • To use this tool you will need to have access to
  • You will need permissions to either read Salesforce Input and/or write Salesforce Output
  • You will need the internal server URL (Find this here)
  • Your specific Username and Password
  • Your salesforce security token

Step 1: Find your URL

Step 2: Username and Password

  • Use the same username and password for
  • Type these into the respective text boxes

Step 3: Security Token

  • Please see this article to retrieve your security token

Step 4: Connect

  • Once you have entered all the information you should be able to connect and the configuration window will change to the Table and Optional parameters

Pic 1.png


Step 5: Choose a table and Output Fields

Once you choose a table it will automatically populate with the available output fields. In the drop down you will have the option to select multiple output fields if you would like.


Pic 2.png


Step 6: Record Limit and WHERE Clause (SQQL)

You can choose a record limit and choose to be more specific in your table search using the WHERE clause. For example, I may want to only look for a specific Account in the salesforce table, so the statement would look something like Account = ‘Jordan Barker’.


Pic 3.png


Step 7: You've done it! Run the workflow!

Once you have entered all of the necessary information you can now run the workflow and retrieve the Salesforce data.


Tips and Tricks


Check First

Make sure from your Salesforce Admin that you have the necessary permissions to read and/or write tables. If you do not have these permissions you will receive a salesforce error from the tool.


Try some sample data

Depending upon the amount of data you are pulling into Alteryx it might be worth just doing a test with some sample data. Once you have confirmed the configuration is working correctly leave the record limit box empty and it will return all records.


Change credentials

If you want to change your credentials please select the change credentials hyperlink on the second configuration screen in the tool.


Pic 4.png


Check your tables!

When using the Salesforce output tool all tables need to exist. This tool will not create new tables in Salesforce.


Password Expiry

If your password expires in Salesforce you will receive a pop-up error message in Alteryx. Currently, there is no Alias option for the Salesforce Connector therefore if you're password expires you will have to manually go and change it in each connector. This is something we are looking at internally to try and create an Alias for similar to that available with the database connections. 


For the time being the easiest alternative is to have your salesforce admin create a generic login and set this password to never expire. If this is not an option you can go to User Settings > Advanced > Disable Auto Config and this will allow you to change the password in your salesforce connectors without getting locked out and the error message popping up.


Common Issues


‘Error: Salesforce Output: The following fields are not members of the target table’


  • Please check that all the tables and output fields exist. As stated above the Salesforce Output tool will not create new tables or fields


‘Salesforce credential disappearing'


  • Please check to see if you have read/write/modify privileges for three directories that the connector uses.
  • C:\Program Files\Alteryx\bin\RuntimeData\Macros\Supporting_Macros,
  • Default macro directory (you can find the path in Options >> User Settings >> Edit User Settings >> Macros, take the search path from there)
  • Temp file directory (you can find the path in Options >> User Settings >> Edit User Settings >> Defaults, listed under “Default Temporary Directory”)?
  • Just right click on each one of those folders and select “Properties.” In there, just make sure in the General tab that read-only isn't selected.
  • You should also navigate to the Security tab to double check that your user group or username is listed with full access.
  • Please also check to make sure these directories aren't running out of space.


‘Access Denied’


  • Please check your permissions to the tables and output fields with your Salesforce Admin


‘Error Sending Request URL Using bad illegal format or missing URL’


  • Please use and copy and paste the URL into the configuration window


'INVALID_LOGIN: Invalid username, password, security token; or user locked out' or 'Alteryx doesn’t support connecting to Salesforce without the security token'



  • Locate the SFDC plugin within your 10.6 installation (for admin this will be likely be C:\Program Files\Alteryx\bin\HtmlPlugins\SalesForceInput, for non-admin C:\Users\[your user name]\AppData\Local\Alteryx\bin\HtmlPlugins\SalesForceInput) and make a backup of this folder to be able to revert if necessary
  • Overwrite the contents of the above folder with new files here


As always if you have any issues please do not hesitate to reach out to Support

5 - Atom

Hi Alteryx,


Does this work for importing Knowledge Articles into Salesforce Knowledge Lightning?



Alteryx Alumni (Retired)

@rgwilcocks If it does, please tell me how you managed it.  (As far as I know, it does not, but I have not really tried.)

5 - Atom

Hi Alteryx,

Is it possible to encrypt the Salesforce login such multiple accounts can run the same workflow?

We have a setup where we are two people running workflows where we download a few Salesforce reports through the 'Salesforce input'-tool.. This workflow is located on our Sharepoint/OneDrive, and thus we have access to the same workflow. When my colleague runs our workflow, the person doesn't get any errors.

But when I run it, I get the following error in the result window:
Error: Salesforce Input (1): {'error': 'invalid_grant', 'error_description': 'authentication failure'}

And the following error in the configuration window of the 

Screenshot 2023-01-05 at 14.23.08.png

As I understand this error, then I am not authenticated because it is a Salesforce Input that my colleague have set up. This has then lead us to have two containers in our workflow, one for my Salesforce input tool and one for my colleagues. We then need to enable/disable every time we want to update our data.

Is there a way to have just one "Salesforce input"- tool, such I don't get a authentication failure when running our workflow? A such solution will help us to utilise the Crew Macro Listrunner.


Best regards,

5 - Atom

Hi Alteryx,


Looks like I am able to upload Knowledge Articles (Knowledge_kav selection in the tool). We have a custom field for the content and for some reason, it limits the content of the articles to about 31,500 characters. In Salesforce, the specific field has been configured to allow up to 131,072 characters. If an Article has anything over 31,500 characters, then it just skips the content completely. Any insight to why this is doing this? Based on the Bulk API Limits (, this should be doable.



Alteryx Alumni (Retired)

Our Knowledge module in SFDC limits article length dramatically.  We have been told that it's just how Salesforce works.  I don't recall our limit, but I think you might benefit from verifying with your internal Salesforce team.

5 - Atom

Hello!  I don't have an option for entering the URL in my Salesforce Input tool configuration.  It only gives me a choice of Production or Sandbox.




I did try the "change credentials" option someone had suggested upthread, but that still does not give me any other options, simply sends me back to the screen shown above.  I need to be able to connect to both our production and QA/Sandbox environments and cannot for the life of me figure out how to do it.  Has anyone had a similar situation and figured this out?