Alteryx Designer Desktop Knowledge Base

Definitive answers from Designer Desktop experts.

Publish to Tableau Server - Error: The file was not uploaded successfully

  • Alteryx Designer
  • Alteryx Server
  • Publish to Tableau Server tool
    • Version 2.0
  • Tableau Server/Tableau Online
    • Version 2020.4+

Error: The file was not uploaded successfully.

Tableau updated their API responses in Tableau Online version 20.4, which causes Alteryx Connector to show an error. This can be worked-around by modifying a Filter tool inside the Tableau macro Connector tool [API response is now "201" instead of "201 Created"].

1. Open the workflow in question that is showing error. Right-click the Publish to Tableau Server tool and select "Open Macro". This will open the workflow which is the Tableau Connector tool itself.

2. Go to Edit > Find, type in "257" and select Filter tool #257.

3. In that Filter tool update the Custom filter entry to:

findString([DownloadHeaders],"HTTP/1.1 201")>=0

Example screenshot:


4. Save the macro and rerun workflow in question. Note: Saving the macro will update the tool on the machine - not just for the specific workflow. You may run into a permissions issue "Access is denied" when saving. Please ensure the user making changes is in a group with full control for the path: C:\Program Files\Alteryx\bin\HtmlPlugins\PublishToTableauServer_v2.0.0\Supporting_Macros or for the PublishToTableauServer.yxmc directly. 

To apply the changes on Alteryx Server

The location of the macro on the Server may be in multiple places. Please make sure to check and update all the following macros on the server (just in case you face errors after modifying just one). If there are multiple instances of the tools, we take this order of preference at runtime:

  1. %APPDATA%\Alteryx\Tools
  2. %PROGRAMDATA%\Alteryx\Tools
  3. <AYX_INSTALL_DIR>\bin\HtmlPlugins (i.e. C:\Program Files\Alteryx\bin\HtmlPlugins)

8 - Asteroid

We are still using a 1.09 version of the Publish to Tableau Server output macro and are receiving the same error having recently upgraded to Tableau Server 2020.4.


We have been unable to get the v2.0 Publish To Tableau Server macro to correctly connect to Tableau Server due to credential/connection issues, hence our continued use of 1.09.


Can you please supply a similar workaround as above for the v1.09 Publish to Tableau Server macro? We have many workflows that are being run via Scheduler and the Error makes it very difficult to monitor what has successfully run vs failed.

8 - Asteroid


Workaround For Publish to Tableau Server macro version 1.09


Note: workaround below is not (yet?) Alteryx endorsed but it worked for us


The filter referenced in the v2.0 workaround exists in the v1.09 macro as well, however it is embedded in another custom macro. So, you'll need to find and open with Alteryx this file wherever the Publish to Tableau Server macro was installed:


Then use 'Find' tool as in workaround above but now looking for tool ID: 30


You will see the same filter as noted in Alteryx workaround in original post above and you can change the filter with the same code snippet referenced above.






14 - Magnetar



Can we expect for this to be fixed on 2021.1 as well as older releases?

5 - Atom

I have a user who is having an issue. She is on 2019.4 Alteryx with the 1.09 macro. When she does the search  for 257, she gets the wrong response from the macro:


Do you have any idea as to what is happening?



8 - Asteroid

@Ed-Alcon  The original solution (editing tool #257) applies only to the version 2 macro.


Please see my solution for v1.09 that requires editing tool ID 30 in this file: that was downloaded/extracted when you originally downloaded the Publish to Tableau Server macro.


This behavior was addressed with the 2021.1 release of Designer. The entirety of the release notes can be found here.

5 - Atom

Would the users have to republish their workflow for the fix to take affect? We have recently upgraded to 2021.1 and issues started to happen again.

5 - Atom

Perfect, really helped.

5 - Atom

Per one of the messages above, I did receive the referenced 'no-permissions' error when attempting to save the macro after removing " Created" from the [tool 257] filter. Does anyone know how to solve for this? When remote-logged into our server machine, I can save the macro just fine, but when trying to save a server-located workflow from my own machine it throws the error.

14 - Magnetar

@HRL I assume you got it figured out, but in the off chance that you haven't... 


Assuming you have administrative privileges on the machine, you can either:

  1. Launch Alteryx Designer as Admin (Right-click > Run as Administrator) and you should then be allowed to save the edits.
  2. Save the macro to your desktop first and then manually drag/drop it into the folder it should go to. You'll likely be prompted with the Windows UAC consent request message to perform action.

Reason for the restriction you're seeing is because Alteryx is installed on a system directory on C drive which is usually protected from programs to make changes if not running in an elevated state.

6 - Meteoroid

@jrgo thanks for this. I was tripped up by this also yesterday. Appreciate the post!

5 - Atom

Does this fix exist for PTTS version 1.08.1?