Alteryx Designer Desktop Knowledge Base

Definitive answers from Designer Desktop experts.

Installation stopped on Python Dependency window

Alteryx Alumni (Retired)

Environment Details

  • Alteryx Designer
    • Version 2020.1+
  • Alteryx Server
    • Version 2020.1+
After launching Alteryx Server or Designer installer, the installation stops on the Python Dependency Window for a long time.


One of the python sub-proccess is stuck. Review the below to confirm:
  1. Launch Alteryx installer.
  2. Allow the process to proceed with the installation.
  3. When reaching the Python Dependency window, let it run for a minimum of 25 minutes.
Note: This step takes between 16 and 25 minutes depending on the Resources allocated to the Server or Local Machine.


This is a known issue that Alteryx is researching - follow the steps below for a workaround.

1. Open Task Manager and go to the Users Tab.

2. Expand the user that is installing the application and look for a python process (python.exe) with about 10 to 13 MB in memory but with 0% CPU committed to it.

3. Right click on the 0% CPU process and press End Task.
4. After this another python process normally shows up and the installer should proceed as normal.
13 - Pulsar

@Loredana  THANK YOU.  I run into this issue every upgrade cycle.  As a Mac user, this is alien and highly frustrating.  

5 - Atom

@Loredana Perfect solution.

Works like a charm. 

6 - Meteoroid

Thank you, this solution solved my issue.

9 - Comet

My experience was that the process that was taking up the most CPU whilst the installer was "hung" was anti-virus. We assumed that the Python install was deploying a large number of small files that was causing AV to choke.


Interesting to see that in your case there is no obvious AV issue.

Alteryx Alumni (Retired)

I got a similar issue when trying to install AlteryxServerInstallx64_2020.3.4.30228.exe. The same screen but no pending Python processes. Nothing suspicious with AV activity either. Average CPU utilization below 10%.  Tried two times in a row with a reboot in between, let it work for 90 mins+ but no visual progress.



The issue was solved by selecting another subversion of the installation file for 2020.3, specifically AlteryxServerInstallx64_2020.3.9.30296.exe. After that everything went smoothly.

8 - Asteroid

Thank you. This will solved my problem.

5 - Atom

I am trying to install AlteryxNonAdminInstallx64_2023.1.1.123 on my Windows 11 (64-bit operating system, x64-based processor)

every time the installation got stuck in the step of installing Python dependencies.

I tried to keep it running overnight and after 12 hours it was still running but never finished the installation.

I tried to End the task (for Python) through task manager but couldn't find it.

I tried to install Python first and thought it might help, but the issue remains the same.