Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

"AlteryxBasePluginsEngine.dll" could not be loaded Network not found Error

7 - Meteor



Hi All,

        Find attached. I have not installed anything new or i have done anything new. It was working fine until yesterday and when i opened Alteryx today i got this. No matter what tool i open i am getting this error.





Error: Text Input (1): The plugin "C:\Program Files\Alteryx\bin\plugins\AlteryxBasePluginsEngine.dll" could not be loaded: The network name cannot be found. (67)



Any Input will be useful. Please note: I Uninstalled and Re installed it.





Hi Ashwin


The general consensus for this type of error is  a anti-virus or security application preventing the DLLs from running correctly. Can you ask your IT to white-list the directories in the attached list and try again please.

Alteryx Alumni (Retired)

Note:  Whenever possible, whitelist the files rather than the directories.  It might be more cumbersome, but it is more secure.

Lisa LePome
Principal Support Engineer -- Knowledge Management Coach
Alteryx, Inc.
8 - Asteroid

I am also getting this error on a few modules now that I switched to AMP. Of 150+ scheduled modules, only 3 of them have this issue. Two of them have the error happen on the Table tool but many other modules are using it without a problem. On the other module, it is the "deprecated" Salesforce Input causing the error. Again, other modules using them without an issue. Any idea what could be causing this? It is not anti-virus or a security application as 95% of our stuff is still running without a problem and 100% was running without a problem before switching to AMP.

I plan to replace the old Salesforce connectors, but the Table tool, I'm not sure what to do about that one. 

5 - Atom



Were you able to determine the cause of this issue?  I am experiencing the same thing and it seems to be AMP related.


Thanks for any help!



8 - Asteroid

I did not. Alteryx Support is currently working on it and escalated the case. Here is what we found out so far.


1. It only happens on AMP, if you can run the module off AMP, it'll work just fine. Specifically on Scheduler. I do NOT get the error if I manually run it regardless of if AMP is on or off.

2. It is related to v4.2.4 Salesforce Input connector (shocker, that thing is the root cause of many issues)

3. Specifically...if you have a Salesforce Input tool in a module, this happens, if you don't have one, it doesn't happen. Maybe other connectors cause a similar issue? Are you using one?

4. If I have a Data Input connected to a Table tool which has an ID "less than" a second Table tool that is downstream from a Salesforce Input, the .DLL error does NOT happen.(basically, if the .DLL for the Table tool runs before the Salesforce Input tool, it "remembers" and can process remaining Table tools)

5. If the Table Tool ID that is downstream from the Salesforce Input is "less than" other Table Tool IDs in a workflow, the error happens. (meaning the Input tool runs before any Table tool)


So clearly the issue is around that connector (Salesforce Input v4.2.4), on AMP, upstream from the Table tools. Specifically around Tool ID values. Which is not surprising because when you are NOT on AMP, you get the "you found a bug" error which is due to the Python-based Input tool not liking when a Salesforce Input tool ID is "greater than" tools downstream from it. That happens, for example, if you have a Data Input that you replace with a live query and now the tool ID goes from 5 (for example) to 100. Everything downstream will have that bug error UNLESS you turn on AMP. Of course, then you get these Table errors.

5 - Atom

15 minutes ago I tested adding...


"C:\Program Files\Alteryx\bin"


to the environmental PATH variable on my laptop.


It seems to help.  Can't confirm that it fixes all as I have not had time to test.


Thanks for getting back to me!

5 - Atom

In former times making changes in the Environment Variables helped me out (but not this time):


Referring to BGirkin´s post, I tried some things out. 

I have Primavera Scheduling DB input and and some are re-placed and have a higher/lower tool id now.


I copied the input container into a completely new canvas first; the tool id starts from 1 again. 

Then I copied the next processing container after it and it created tool id 2, 3, 4 etc. in it.

Also I tried it vice versa with the processing container first and then the input tool.

The result is, that I get a new tool id, starting from 1, which is nice but this did not help me.


The only thing which worked out was... switch on AMP on Alteryx Desktop and then to run it one time. 

Then the failure message disappeared and all data went through the workflow as it should.