Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

We found a problem with some content when opening excel file (using Output)

8 - Asteroid

I've seen a few posts about this error message but nothing that I could use as a solution. 


I'm outputting to an excel sheet and specifying that cell range to output to. I'm not sure if it's worth noting that the range I specify in the workflow is much larger than the actual range as I don't ever have the exact same range each time I output. 


I've tried creating a completely new Excel file, and I've tried using both .xlsm and .xlsx. It always opens correctly the first time I run and open the worksheet (after creating a new file to use). And it looks just how I need it to look. But anytime I run again and open I get the error message. 


I've tried running from both Designer and from the gallery. 


Any ideas? 







17 - Castor
17 - Castor

When you specify the range, are you using the notation filename.xlsx|||Sheet1$A1:E100 or something like that? I assume you're not writing to a named range in Excel.


The number of columns is always known, right? So that can be exact, like in the example above, there are 5 columns A to E.


If you don't know how many rows of data you're writing, you can just omit the number after E so that it becomes filename.xlsx|||Sheet1$A1:E  - this will only create rows to the end of the dataset. Perhaps specifying a different cell range to the dataset you're writing is causing the error.

5 - Atom

I have been having the exact same issue. None of the recommendations to fix it that I've come across have worked.

5 - Atom

Do you have any special character in your path, e.g. ' ? if yes, remove them.

5 - Atom
I have same issue. None of the recommendations to fix it.
5 - Atom

Has a solution been found to this? I have the same issue and none of the suggestions on this thread or any similar threads work for me. 

6 - Meteoroid

Same issue here. Has anyone found a solution? Thanks.

5 - Atom

I have had the same issue (without the named range- just outputting to a named worksheet) on multiple workflows for over a year now. Like everyone else, none of the suggested solutions I have found have worked.

15 - Aurora
15 - Aurora

hey, anyone who received this issue, are you able to supply a workflow file that causes this? Happy to have a deep dive but a hard one to replicate.