Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Warning message: Newlines detected

7 - Meteor



I'm using Alteryx version and I'm doing a simple export from an Informix database to a text file.  The Text file output option I've selected is 'Comma delimeted text files  .csv'  however I've chose "|"  (pipe) as my delimeter.


When I run the extract Alteryx indicates the file transfer was successful, however it gives a Warning.  The message is:  "Newlines detected in data, output file might not be readable by other tools."


When I look at the Input and Output sections of the Output dialog, I see that the same number of records that were read were also written out to the text file.  So, it doesn't look like I added any newlines to my output text file.


One other bit of information on this... for my Input Data tool that reads the table from the Informix database, I am using the SQL editor option to convert select text fields that natively contain a "|" (pipe) in some of the field values.  To convert, I'm using a simple Replace function to replace pipes with an underscore character.


Does anyone know what the Newlines detected Warning message is telling me?  I've tried to research on Help and in this Forum, but I've had no luck.  Any insight is appreciated!



ACE Emeritus
ACE Emeritus

I think it is telling you you have text fields with multiple line in the value. The resulting CSV file will hence have rows split over multiple lines which can confuse some import tools, plus I think Alteryx uses the UNIX style endings which other windows tools dont like.


For example if I save:



as a CSV with | delimeters the output is:



(Where \n is the line feed character.)



Hope that makes sense.

7 - Meteor

Thanks for your reply - the screen shots were very helpful!!


If I understand correctly, I will need to count the rows in my destination database to ensure no rows have been added. 



9 - Comet

Hey sd,

If you want to elimiate this warning, it may not be a bad idea to try another data stream and instead of using the output tool to "|" delimit your data, you could run a transpose using "|" as your separator. Be weary to set your field size to be large enough to take your row of data. Once you do that, you can then send the data to the output tool and set the file to c:\filepath\filename.csv. The set your delimit option in that toll to \0 (backslash zero). Similar to what Ned Harding has recommended for inputting data, that \0 will send your data to your file as it with no modification. The last thing you need to do in the output tool is make sure that you set the quotation for your data to "Never". If you don't do that last part, your data will have double quotes added to each side, so from this: Record 1|Doe, John|121 Main Street|San Diego|California it'll look like this "Record 1|Doe, John|121 Main Street|San Diego|California". As you know, that can create issues in your data or with other applications consuming your file/


Again, maybe not what you are looking for but if you're looking to pipe delimit your data and not get errors, you can give that a try!