Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.
SOLVED

Text Tool or Excel Input not outputting.

Number4
8 - Asteroid

I've been running for quite some time.
I needed to make an adjustment to it, where I added a Text Input tool and a Join.

 

The text input tool would not output anything.  In fact, the Select Tool next in line only showed *Unknown.

I changed it to an Excel file, with the same results.


However, if I copy the input tool with the select and put it in a new workflow, it runs as it should.

 

It's one column with 13 rows.

 

***Updated with images***

 

Input Tool.pngText Tool.pngI have a workflow

12 REPLIES 12
IraWatt
17 - Castor
17 - Castor

Hey @Number4,

Do you have a screenshot of this happening. Also are there any error messages in the results window?

gabrielvilella
14 - Magnetar

If you copy that Text Input and paste on a new workflow, does it work? Are you are able to share the workflow with just the Text Input? 

Number4
8 - Asteroid

If I open another tab in the same workbook, and copy the text input tool or regular input tool into it, it works fine.

I've save/closed/reopened the workflow.  Installed the latest version of Alteryx, restarted the computer etc.   Same thing.

gabrielvilella
14 - Magnetar

Well, I would just copy everything (Control + A and Control + C) then paste into a new workflow and save it. Something is damaged on the original one. 

Number4
8 - Asteroid

Great, so I save the workflow progress to an output file.  Then do the missing step in another tab and output that result to an yxdb file.

Then I input that file back into the workflow to process from the fail point on.  And this input tool will not output data.

You can click on any of the input tools and see that they have data, but when you click on the output doohickey, there's nothing.

gabrielvilella
14 - Magnetar

As I mentioned, the workflow file has been damaged. Please copy and paste all tools into a new workflow and create a new workflow file. 

cfgurney
5 - Atom

I encountered the issue of the Text Input tool not outputting in a workflow. This was a workflow that had been created and updated repeatedly in the past 4 months. The workflow had 3 different Text Input instances and 2 of the 3 did not output any data, Interestingly, a new Text Input instance added to the workflow didn't function either.

 

@gabrielvilella suggestion of copying all elements and pasting to a new workflow did resolve the issue. I am running Designer 2022.1.1.25127

gregx
8 - Asteroid

The same issue happens to me. Even I made a copy, after some time it got damaged again. How can we sustain the workflow working ?

roughchr
6 - Meteoroid

I get the same issue. The workaround of copying all the tools to a new workflow worked for a while but that has stopped working now. If I copy and pasting the text input and select tool to a new workflow – this runs without any issue in the new workflow. If I remove all other tools from the workflow – the text input/select tools  then run without any issue; but when I add the other tools back in they no longer run (although the select tool retains the fields).

Labels