Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

SharePoint List Output: An error occurred while writing record. Record was partly written.

15 - Aurora

Hello everyone,


I am trying to upload an excel file with 2086 rows and 118 columns using a SharePoint List Output tool with "Delete List and Append". It is definitely connecting to the SharePoint because all of the data is being deleted. However, it is not uploading a single cell, and this error occurs: "Error: SharePoint List Output (3): An error occurred while writing record. Record was partially written. Check List in SharePoint." Any thoughts on what could be causing this?


We made sure the data types all matched up using a Select tool. We also tried doing the same uploading with only 1 column and 100 rows and the same error occurred. It only didn't occur when we had 1 column and 2 rows of data.


Please let me know if you need any more information, and have a great day!


Best Regards,


5 - Atom

Just here to say it is June 2022, 3+ years, after the original post and still no fix as I am experiencing this issue. 

8 - Asteroid

I have the same issue.  However my list writes out without a problem to one Sharepoint list.  When we tried to migrate to a new site, I am running into the limit issue and getting the error.  Both sites seem to be configured exactly the same as far as we can see.  Are there any updates on this issue?

5 - Atom

For me it happened when one of the column text was too long to fit in single line of text data type in sharepoint list.Once i fixed it, the issue got resolved

6 - Meteoroid

After spending about 2 days debugging i was able to resolve this error. In my case i am moving large multiline text data, even thought the column option was set to multiline it was randomly crashing with this same error, i was able to fix it by changing the following option in SP for the column 

Specify the type of text to allow: 

From Plain text to Rich text


Hope this helps someone !


8 - Asteroid

Yes, most of the time it is a data type error.  My last error was due to columns getting shifted in tab delimited file.  Moving to pipe delimited after this error.  A text value was shifted to a numeric column, throwing the error.