Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Python tool loses code

17 - Castor
17 - Castor

Has anybody else lost their Python code? It has happened to me twice. I go to run my workflow and see that my few hundred lines of code have been deleted and replaced with the standard default:


Alteryx Alumni (Retired)

Hi, something similar happened to me yesterday. I didn't have any issues until I upgraded Designer from 2019.1 to 2019.2. I was able to recover the code by creating a copy of my workflow and changing file extension from an Alteryx workflow to a text file. Then you can see the workflow contents in HTML like format. You should be able to find your code.


Hope this helps!

5 - Atom


I seem to have the same problem (at least, my Python Tool is losing Code altough I safed it). I work with Version 2018.3 and am unable to update as I am no Administator of my local mashine.


Anyway, is there a fix or a solution available by now (as the topic is about one year old)?


I would really appreciate it, thanks a lot in advance.





I am sorry, I did not read the other pages, so I was unaware that this problem seems to be a bigger one and persists.

7 - Meteor



Happened to me today. 2019.3, admin. I hope it is solved soon or a workaround is made



5 - Atom

what is the status on having the Alteryx /Python problem fixed?

Yesterday i downloaded the latest version of Alteryx and the code worked fine after opening/closing/running etc.



Today it suddenly just lost the code:





Should we be using the Python tool or not?

Alteryx Alumni (Retired)

Hi @CdReddy,


Thank you for your post.


Could you please show the screenshot of workflow OnionPredictor.yxmd (instead of OnionPredictor2.yxmd) in the second screenshot?




Paul Noirel

Sr Customer Support Engineer, Alteryx

5 - Atom

Morning Paul,

Both screenshots are attached. The first one was what the workflow looked like when i stepped into the Jupyter notebook at the end of the Thursday.


On Friday I continued to work on it. Later in the day the Python script got erased. I did not save the file during the period, hence i just reopened the file and saved the anomaly file as OnionPredictor2. Essentially, we lost half a day's worth work because the Jupyter script disappeared.

5 - Atom

Piling on here to report that I am still experiencing this issue. This has caused some embarrassing downtime for dashboards at a client - someone opens the Alteryx workflow, runs it to update a Tableau data extract, and the Python code fails silently, outputting an empty Tableau extract and breaking the dashboards.


Until a full fix is made, could you please implement some enhanced error handling? Right now it looks like the default code can run silently and output nothing, without raising any errors.


Note to others experiencing this issue - you can restore the python code by finding the .bak file, opening it in a text editor, and copying everything between the <Notebook> and </Notebook> flags to the corresponding area in your .xymd file (also open in a text editor). It is also a good idea to save & maintain your python code separately, then copy/paste into the Alteryx tool at runtime.

9 - Comet

I just ran into this error, I'm on 2019.3.5.17945 (Non-elevated)...I typed some code into the Python tool, went to another workflow, came back, and it was gone from the Python tool.


Thanks to everyone who pointed out it's still in older .yxmd, that just saved a chunk of work.




8 - Asteroid

Hi @PaulN and Alteryx Community -


I don't find a definitive answer on how to resolve this issue. This has caused a loss in code (thankfully saved a copy of my scripts in backup) in the workflow and issue has caused problems as mentioned by other users. 


What is the plan of action on this issue? Do we already have a fix for it? 


To all users: Can you confirm if this issue persists on workflows that have a wireless connection to your Python tool? 





7 - Meteor

I ran into this issue in 2019.3.6.20285 after having not seen it for probably the last 6 months.  Sad to see this is still an ongoing issue to many versions later.