Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Python tool and Alteryx.write error : Cached data unavailable

5 - Atom

Hello Community, 

I have been trying to add input/ouput with the read and write script lines to the  Python tool, the following error occurs : 

Cached data unavailable -- run the workflow to make the input data available in Jupyter notebook (\\Mac\Home\Desktop\Missions\Dassault prédictif\Playground - Alteryx\Data\jupyterPipes.json)

Capture d’écran 2020-10-15 193907.png


the error suggests to run the flow, I did that several times, no change. The strange thing is that when I isolate the '"#1") alone in another python tool ( see following picture) it works well :

Capture d’écran 2020-10-15 193934.png 

This error occurred for the "Alteryx.write" as well and I have tried to downgrade Alteryx version from 2020.3 to 2020.2, it didn't resolve the problem. It's quite random. Does anyone have idea how to resolve this and why is it occurring ? 


Best Regards, 

Salma Ben Tarjem


Hi @SalmaBenTarjem , can you please share us a sample workflow. Thanks.

5 - Atom

@WilliamR, When testing the problem, the error seems to occur when we redefine a directory in the python code with the 'os.chdir()', It is possible to work without this commande in the code as a temporary solution, is there an explanation or a better solution ? I leave you attached an example of the workflow.

To be able to reproduce the error please change the file path to a valid one inside the os.chdir()

Thank you. 

5 - Atom

Was this ever resolved? I'm running into the same issue. When I was using version 2019.2 I never had this problem, but when I upgrade to 2021.2 I started receiving this error. 


I even deleted the python tool, re-added it and then tried running the workflow, but the Python tool does not recognize any of the cached information, no matter how often I run the workflow. 

5 - Atom

i had the same issue with the working directory. solved it by saving the working directory before changing it then changing it back before writing it out of the python tool. 





7 - Meteor

I’m getting the same error and have no idea how to solve the issue… Has this issue ever solved?

7 - Meteor


Has anyone gotten any reply or resolution on the above issue? This seems to be an issue with many. I am facing the same error, and have experienced the same as all above - 2019.2 worked way better than 2021.3(which I am using currently). I will be honest - Python tool has been working very very very badly and being in a corporate, and an able Python developer, I feel Alteryx is an unreliable software to even use Python in any scenario. Not sure if Alteryx is vocal about it. But, the product is sh**ty(sorry for my language here) as it has been frustrating with such an incompatible tool.


Below is my error





Please fix this!!!

8 - Asteroid

I have found that reading inputs within the python tool can be made much more reliable by including a metadata read before attempting to read the data:

input ="#1")

This was able resolve issues I was having when attempting to read the data stream.

Hope this helps.