Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Publish to Tableau Server Tool - Error when tds file is attached

6 - Meteoroid


I was trying to use the new Publish to Tableau Server tool and it worked pretty well without attaching the tds file.

I'm wondering if anyone can explain this error message? Do I have something wrong with the workflow or the tool or the Tableau Server settings?

Thank you!

6 - Meteoroid

Anyone got an idea?

7 - Meteor

Could you elaborate on what you mean by attaching the tds file? Can you share your workflow? The Publish to Tableau Server tool does a POST request to the Tableau Server's REST API. Since you're getting a response from the Tableau REST API with an error, I did a quick search of that "400011" error to find out more.


Tableau explains it as: "The data source could not be published for some other reason than those specified earlier."


According to this user's experience with Tableau's API -- --  There are specific instances where this error will occur and possible solutions:


  • Publishing a TWB for a workbook that references external files (TDEs, XLSX, etc). Solutions:
    1. Re-save as a TWBX and publish the TWBX
    2. Publish your datasource to data server first, and connect the workbook to that datasource on data server
  • Publishing a TWB that references a data server source that doesn’t exist on that Site. Per the previous post on the topic, you can publish a TWB that connects to a data server source with the same name on a different site. But if you haven’t published the data source first, expect 400011 to be your fate
  • Publishing a TWB that references a data server source that published correctly, but didn’t embed credentials that are necessary. This may seem strange, but Tableau Server generates thumbnails for each worksheet at publish time, so if it can’t verify the server connection because it lacks credentials, then you’ll get a friendly 400011 response code as a reminder. Side Note: If you ever see your publish times take a long time, it is probably held up on generating the thumbnails, and it is a sign that your databoards are going to be miserably slow when people view them as well. Stop showing so much unfiltered data without doing some guided analytics first.

^ These steps are pretty specific use cases to Tableau, not Alteryx, if none of that helps is it possible for you to output to a .tde, open tableau, and publishing your data source?


6 - Meteoroid

Thank you so much for your reply!

Please find this screenshot. I used the new Publish to Tableau Server tool to publish a hyper file and used the option in the blue box to attach a tds file. Alteryx Publish Error.PNG

6 - Meteoroid

Thank you so much!!! It works now. Just edit the dbname in the tds file.

5 - Atom

I've been getting the same error as above, but I've tried the solution above and keep getting the same error (Error Code 400011 Bad Request) when I try to publish incoming data in my Alteryx workflow as a .tdsx.  The workflow publishes successfully when I simply try to publish as a .hyper extract (nothing entered in the "Data source metainfo" field).  I have gone into the .tds file and changed the path for dbname to:  dbname="Data/Extracts/TEST HYPER.hyper' (first screenshot below).   My settings in the "Configure Data Source" window are as shown in the second screenshot below.  Keep getting the same Bad Request error.


I have tried both regular path name for the .tds location and UNC path.  Tried including .tds at end of filename in "Data Source Name" field and not including it.  No luck.


Both Tableau Server & Tableau Desktop I'm using are 2018.1.


Any suggestions?


tds file edit.png


Configure Data Source Window.png


8 - Asteroid

Not sure if you've made your way through this issue or not.  But, in case you haven't, I think the issue is that the space between "TEST" and "HYPER" in will be replaced with an underscore in the file name on the server.  So, in Data Source Name, this will be "TEST HYPER".  In the tds, it needs to be dbname='Data/Extracts/TEST_HYPER.hyper'.


I've found that hyphens are also replaced with underscores.  I am guessing this means anything other than alpha/numeric is replaced with an underscore.  But, I have not personally confirmed this.

5 - Atom

Thank you for saving the day!

7 - Meteor

Hello! I'm running into the similar issue.

- I've changed the version to my current version. On Tableau Desktop & Server version 2019.1 (image attached below)

- Changed the naming convention to replace spaces with _ 

Not sure what I'm missing. My TDS does contain calculations if that makes difference?