We’ve extended Inspire Early Bird Pricing until March 1. Register now and enjoy 20% off conference passes and 10% off training passes. P.S. Don’t forget to bring friends! When you sign up for five or more tickets, you get an extra 20% discount on conference passes. Learn more now.

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Google Drive Tools won't write to Shared Drive 'Failed to read port assignment'

nickdreach
8 - Asteroid

We use the deprecated Google Sheet tools and want to replace them with the Google Drive tools.  

 

If we use the older (non-AMP) versions we are able to write to My Drive without difficulty.  But what we need to do is write to a Shared Google Drive, so we need one of the newer (AMP) versions.

 

Using the latest v1.2.1 of the Google Drive Output tool we can neither write to a Shared Google Drive nor write to My Drive either.  We consistently receive a pair of errors:

 

'Internal error: Failed to read port assignment'

'All incoming anchors closed, but plugin has errors'

 

I've experimented with just having AMP turned on and also having AMP turned on with Engine compatibility mode as well.  I've tried three different ways of connection, via DCM, via the Web Browser option (with and without 'Connection through Own Google App checked').

 

The Google Drive Input tool is no better - old versions can read from My Drive, but the newer versions that should be able to read from My Drive and Shared Drive are unable to do so, with the single error:
'Internal error: Failed to read port assignment'

 

Designer is 2022.1.1.42604, it doesn't make any difference running it as an Admin.  Tried deinstalling and reinstalling the tools multiple times, read every article I can find that mentions either of the errors....It doesn't make any difference to the output tool whether it is being passed something from a database or just from a file or Text Input tool.  It doesn't matter whether you try and output a .xlsx file or a google sheet etc, whether you choose to rename or overwrite or append....there doesn't seem to be any combination of options which will work.

 

Has anyone encountered this and been able to resolve it?

2 REPLIES 2
nickdreach
8 - Asteroid

I can see that in the next version of Designer (2022.3) after ours (2022.1.1.42604) - the Google Sheet tools are called out as deprecated with the advice 'Google Sheets connectors in older versions prior to 22.3 should be replaced by Google Drive connectors from 2022.3'

Did anyone experience the Google Drive tool problems I've mentioned whilst on a version of Designer earlier than 2022.3, then have it fixed by upgrading to 2022.3 or beyond?

nickdreach
8 - Asteroid

So, we got it working but in a very unsatisfactory manner.  I installed the new version of Designer (2022.3) up from our version - did this as the admin version (already having the non-admin version of 2022.1 installed.).  At this point the old version of Designer could then write to a shared Google drive using v1.2.1 Google Drive Output tool. 

 

But to confuse matters I deleted the Google tools entirely, rebooted - started my old version of Designer and it could read to and write from a Google Shared drive - but the tools weren't installed! (nothing in C:\Users\<user name>\AppData\Roaming\Alteryx\Tools)

 

I then deinstalled both versions of Alteryx and reinstalled the 2022.1 non admin version again - it ended up with a slightly different version number 2022.1.1.42654 - previously I had 2022.1.1.42604.  Downloaded just the latest 1.2.1 Google Drive tools....and they just worked.  What. A. Palaver.

 

We have yet to see whether they 'just work' on the server or not - I don't really want to mess around as outlined above on the server.

Labels