Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Error opening connect string: Can't create Data Source Object

6 - Meteoroid

Error - Error opening connect string: Can't create Data Source Object


We are trying to use Alteryx scheduler to take data from an Access database, without luck.

12 - Quasar



is the workflow running fine from the local machine ?

what option are you using when you use scheduler

from the Local disk or in the Scheduler DB?


Did you configure the ODBC at server level for MS Access?




20 - Arcturus
20 - Arcturus

Is the access DB open in another application or is the workflow already open on another Alteryx instance?

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and restart. Order shall return.
Please Subscribe to my youTube channel.
5 - Atom

After I installed the Microsoft Access Database Engine 2010, it worked fine.


5 - Atom

Can you provide some clear instructions on installing Microsoft Access Database Engine 2010. Should I just download directly from net or is there any other process?

13 - Pulsar
13 - Pulsar

@TroyXman solution worked for us. Thanks!


The Alteryx Server didn't have Microsoft Office installed, so it didn’t have the system files/drivers necessary to perform the actions my workflow was requesting. My coworker installed the Microsoft Access 2010 Runtime and problem solved!


Thanks again for pointing us in the right direction!

7 - Meteor

Good morning,


today while saving a workflow on the gallery I received the error ,you could find in attached is about tool 22 an input date, where I entered the following path referring to the dfs

"\\ v-fsfile \ Allitaly $ \ db_cambiali \ file_da_caricare \ cessione_db_cambiali_mm _ *. Accdb"

The asterisk let me to choose all the files that have the same name but that differentiate for the part replaced by the asterisk. they are identical accdb files with the same extension and with the same name as the internal table.

How can I solve this problem identified with "error opening connect string: can not create data source object", in the second attachment you can read the settings of input data


Thank you

7 - Meteor

You can download the Access database engine from here: 


Download and run the executable, there are no options that you need to select.

7 - Meteor

The link I posted no longer works - in case microsoft change the location, try and search "access 2010 engine" - it should be the top result.

5 - Atom

I have the same problem as "Ferrari " but with an MS excel file, I have a workflow that uses the file path as the output so it can pick certain text - but when i upload to the alteryx server it gives an error saying "  [Workflow.yxmd] Tool 36 - Error opening connect string: Can't create Data source Object - Class not registered, how can i fix that ?