Get Inspire insights from former attendees in our AMA discussion thread on Inspire Buzz. ACEs and other community members are on call all week to answer!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Designer does not display intermediate data in results window when using a .yxdb file

6 - Meteoroid

I noticed that when I run a workflow that reads in a .yxdb file, I cannot see any data in the results window before/after tools. Data only appears after the last tool. Otherwise, the results window shows the message "No data available. (Use Ctrl+R to run the workflow.)"


If I replace the input file with a .csv the issue goes away. How can I see tool input/output results with a .yxbd file?


I tried looking at this solution but it did not solve the issue

ACE Emeritus
ACE Emeritus



if you are confident that you don’t have the following issues;


1) a single row of data is so large (memory wise) that it can’t be displayed within the limit set in your user settings, in which case this would be expected


With this point, I know you mentioned it worked with a .csv file, but .csv files contain different properties on input, for example strings are truncated to 254 characters (this can be changed in the input tool options), and therefor it’s possible that data is only being made visible when you use a .csv file because you’ve severely truncated the data you are working with, and as a result the memory to show even a single line is not exceeded.


2) browse tools are turned off in the workflow runtime settings


Then your next step should be to raise this to Alteryx support so they can get a handle on this issue (

6 - Meteoroid

When I use a Browse tool, I am able to see intermediate data. It's only when I click on a tool and try to see the data before/after passing through the tool that I am unable to see the data.

17 - Castor
17 - Castor

Hi @DesiPilla ,


Click the green node coming out of the tool to show the results coming out of the tool and the node to the left to show records coming into that tool:





If you have records on the input but not on the output then you've done something in that tool to remove the records. Follow it back until you see records, this will allow you to identify where the records are dropping out. This is usually because you have an error in your workflow.





6 - Meteoroid

Though not a perfect fix, I went and upped my memory limit and it *worked*. While the individual rows were not too large themselves, it seems the issue goes away if my memory limit is large enough that ALL rows can be displayed at once.


The node memory limit before was 1024 KB, which would display 13k / 19k rows from the csv file but none from the yxdb file. When upped to 1 GB, all rows would display from either file.


My designer seems to process csv files significantly faster though, so it's easier to just work convert my yxdb files to csv and then load them.