Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Alteryx 2021.2 not responding

5 - Atom

Hi ,


I am facing issues while working on Alteryx designer. It stops working for minutes while I develop any workflow. Configuration pane for the tools don't load quickly as it is supposed to. It takes nearly 3 mins to load. No other application on my desktop is functioning as I am facing with Alteryx. However, this is the first time in two yrs of usage, I am facing this issue.


I've tried reinstalling the designer thrice, but the issue still persist. 


Could anyone help me solve this issue.


Note: I am using an organization's laptop. 

19 - Altair
19 - Altair

Hi @ssrenuvas 


While developing a workflow, Alteryx Designer engine regularly makes dummy calls to all Input tools to retrieve metadata and display fieldnames and types in the various downstream tools (Auto Configure).   Some external sources, such as remote DBs, Azure, Google,  AWS, SalesForce, etc,  can take a long time to respond so the entire workflow stops until all the responses are received.   


You can Disable Auto Configure in the User settings.  



With this turned off, metadata will only refresh when the workflow first opens or if you press F5.  This will speed up overall development time, but any new fields you add in formula tools, etc won't show up in downstream tools like the Sort tool. 


To get the best of both worlds, I use the following approach.  For all inputs that are slow to query, I do an initial run to store the data in yxdb files.  I then use the yxdb files as data sources while developing the rest of workflow.  The input section of the workflows look like this.




When you need to initially get the the data and/or metadata, disable the Workflow Development container, so the .yxdb file can be refreshed.  When developing the workflow, Disable the Meta and Data Refresh container and Enable the Workflow Development Container.  The metadata will be read quickly from the .xydb file so your Designer will remain responsive and you'll be able to add and modify fields as required further downstream.




7 - Meteor

Same issue. Even with the auto config disabled. It freezes with "Not Responding" for 10-20 secs everytime I click anything. Very annoying, unusable.

5 - Atom

I"m having same issue - i open the workflow, run it (fairly large file).  I've expanded the RAM usage from 25% to 50%, but when I enter into a connector to make a change then click out - it says not responding for minutes - i have to shut down.  I've rebooted, optimized computer - has anybody received a satisfactory response?

5 - Atom

Having the same issue. Have tried everything above. As long as the workflow is very small, it's responding fine, but it seems Alteryx Designer is not built for large complex workflows. Is that the case? If so we would have to look for other technology alternatives.



5 - Atom

I am also having the same issue. I update Alteryx recently and it is constantly non-responding. My workflows worked well until I updated Alteryx. This is impossible to use and incredibly unstable.

14 - Magnetar

Hi, @CatManKuhn 


What version are you used like v2021.x.x.***** ?

7 - Meteor

I'm currently having the same issue, let me know if you guys managed to resolve this issue and how.

5 - Atom

hey guys is there a solution for this - I am experiencing this as a new version of Alteryx was installed on the AWS we are using... 

Vesion is 2021.2.2.45235


7 - Meteor

I managed to solve it in a way that I don't know if it's the "right" one, but it worked for me:





I selected this first option