Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

AMP engine: Anchor was not closed

max1111
7 - Meteor

Hi!

 

When saving the workflow on desktop I got the error: Anchor was not closed (please find the error attached), but it runs in the gallery without error. What could be the reason? 

 

Just some details on the workflow: My workflow consists of 2 macros, I need only one macro to be run by AMP engine, that's why I have AMP cheked for the macro and for the workflow ( not for the second macro).   

 

Thank you in advance!

5 REPLIES 5
nbondarchuk
Alteryx
Alteryx

@max1 Could you please provide details about the workflow and share a sample of the Input data?

NeoInfiniTech
9 - Comet

Hello @max1111, I had the same error today after having updated from Alteryx Designer 2023.1.1.123 to 2023.2.1.7.

 

In my case, it was an existing workflow that worked fine in 2023.1 but produced the same error as you stated above when I ran it on 2023.2. Upon closer examination, I found out that it was because of two disabled control containers nested within a parent control container. After deleting (or enabling) the nested control containers, the workflow worked fine.

 

Your workflow working fine in Gallery could be because Gallery might have a different Alteryx Engine version installed.

 

Could it be the case that you are experiencing the same issue with your workflow, as in one of the two macros having the same scenario? I opened a ticket about this (case number 00664590) today.

RexLi10
5 - Atom

Hi, @EnthusiasmAYX. In my workflow, I have some nested control containers under the parent control container. And in some situation, some nested containers need to be disable. And I can't delete the nested container as I need them to set the sequence for the workflow. May I know if there is another alternative solution that I can solve this issue without delete the control container and allow nested container to be disable? Many thanks.

NeoInfiniTech
9 - Comet

Hi @RexLi10, I'm afraid there is no option other than to wait for a release that fixes this issue. It may be fixed with the next release of Alteryx Designer, so I would suggest that you wait for the version 2024.1 to use the control containers without any issues. The same issue occurs with the version 2023.2.1.51 (23.2 Patch 1) and I think it wouldn't be any different with 2023.2.1.89 (Patch 2) as there are no release notes regarding nested disabled control containers for Patch 2 either.

 

Official reply below, please ignore my reply.

nbondarchuk
Alteryx
Alteryx

Engine team has been fixed two issues related to the nested disabled Control Containers:

1. GENG-3404: Control container with nested disabled control container inside causes an error

 

2023.1.1 (Patch 6) March 7, 2024

2023.2.1 (Patch 3) March 14, 2024

2. GENG-3381: Macros that contain a control container and a nested macro with a relative path causes error

2023.1.1.336 (Patch 5) January 16, 2024

2023.2.1.89 (Patch 2) January 25, 2024

Labels