cancel
Showing results for 
Search instead for 
Did you mean: 

Private Gallery - App that includes download tool

SOLVED
DataBlender
Bolide

I have created an app which contains a download tool but I note that the gallery restricts such apps.

 

I don't want this app to be publicly available, but rather only to members of a private gallery. Is this restriction still in place or is there a way around it (other than sending to curator for review)?

Alteryx Certified Partner
Alteryx Certified Partner

If you have a private gallery on your own server, then you can allow the app. But it sounds like you're using the gallery at Alteryx and you'll need special permissions. 

 

Cheers,

Mark

ACE & Alteryx Certified Partner
Chaos reigns within. Repent, reflect and reboot. Order shall return.
DataBlender
Bolide

Hi Mark,

 

Thanks for that, I can confirm that it has been published to a private gallery. 

 

Is there a setting that you need to configure in order to allow it to run? The app fails with the following error message:

 

The job [Name of App] did not complete successfully and resulted in the following errors:

  • Error transferring data: Couldn't connect to server (Tool Id: 78)
  • Error transferring data: Couldn't connect to server (Tool Id: 78)

 

Tool 78 is the download tool but I'm able to run the app locally/on the server without issue. In settings, the run mode is 'unrestricted' and I have tried toggling 'Private data exemption' to both yes and no but neither seem to fix the issue.

Alteryx Certified Partner
Alteryx Certified Partner

As a gallery adminstrator you can enable the workflow to run:

Editing a Workflow

 

Click the Workflows option in the left menu.
Click the name of the workflow. The Edit Workflow page displays. Modify the workflow’s description, add a tag, or change the icon image, and click Save.

Within this window an Admin can also modify the following:

  • Run Mode: Determines the level that workflows are permitted to run in the Gallery. Workflows that contain certain tools or access may need to be blocked. The Default Run Mode is selected when the server is configured. If a user has a workflow that uses one of the prohibited tools in a safe manner, they may request an exemption so it can be run in the Gallery and the Run Mode option can be changed for that specific workflow.

    • Unrestricted: Any workflow can be run.

    • Semi-safe: Workflows using certain tools will be blocked from running.

      These include: Run Command Tool, Download Tool, Email Tool, R Tool,

      Run Command Event, and Send Email Event.

    • Safe: Workflows using certain tools, or accessing/storing data on non-

      local drives, will be blocked from running.

      Safe and Semi-safe options can only be used if the Worker > Run As setting has been enabled.

ACE & Alteryx Certified Partner
Chaos reigns within. Repent, reflect and reboot. Order shall return.
Highlighted
Jason-PK
Atom

I see this marked as a solution but I am having the same issue and the solution provided below doesn't appear to resolve it. A workflow with the Download tool is configured to run in Unrestricted mode but fails when run in our private gallery. It works when I run it in Designer on the gallery server so it doesn't appear to be a firewall issue. Is there some other trick to get a Download tool to run on the gallery?