Community Spring Cleaning week is here! Join your fellow Maveryx in digging through your old posts and marking comments on them as solved. Learn more here!

Alteryx Auto Insights Knowledge Base

Definitive answers from Auto Insights experts

My KPIs/Measures are not visible

nathan_love
Alteryx
Alteryx
Created

Issue

I don’t see all of my KPI’s / Measures available to me in Auto Insights. I have to filter to get them.

Cause

Your KPI’s / Measures are likely contained within one numeric field and one field with the name of that KPI. In order to have them as individual measures in Auto Insights, you will need to have a separate column in your dataset with each KPI and the corresponding numbers underneath.

Resolution

You can use the Transpose tool to re-format all of these dynamically for you. 
Select all fields apart from your numeric field and KPI names field from the ‘key data columns’

  • Set your KPI names field to be the ‘name’ and the numeric field to be ‘data’
  • You will then need to define the method for aggregating, this can be ‘Sum’. All the numbers will remain the same in this instance
  • Wherever the data now doesn’t appear, it will be represented by a null value. You can use a Data Cleansing Tool after to replace null values with a 0
Before:
image.pngimage.png

After:
image.pngimage.png