Now that it's live, don't forget to accept your certification badge on Credly today! Learn more here.

Alteryx Analytics Hub

Find answers, ask questions, and share expertise about Alteryx Analytics Hub.
SOLVED

Can't connect to hub through designer - SSL issue?

CameronSteele
6 - Meteoroid

I'm setting up a test environment for hub on an Azure hosted VM.

 

I've got it installed and running, created a self signed certificate that's installed on both the server and my local machine.

 

Logging in through the browser works fine and I don't get the security messages I would expect to get if the certificate wasn't installed on my local machine.  However, designer doesn't want to connect to hub at all. It just says "Could not connect to Analytics Hub" each time.  I've tried the root site and specific sites.

 

Are there any special steps to get designer to use the self signed certificate I may have missed?  Anything else to check?

 

11 REPLIES 11
grossal
15 - Aurora
15 - Aurora

Hi @CameronSteele,

 

did you add a Hub-License inside your designer + add a User-License on the Hub for you?

 

 

Best

Alex

CameronSteele
6 - Meteoroid

Hi Alex,

 

Yes, I have set myself up as a licensed user in Hub, added my user to a site, and applied the Hub license to my local designer.

 

Thanks,

 

Cameron

grossal
15 - Aurora
15 - Aurora

I found another on our installation notes saying:

 

"Change certificate installation folder to Trusted Root Certification Authorities"

 

Could you try this?

CameronSteele
6 - Meteoroid

The certificate is already in the Trusted Root Certification Authorities folder.

grossal
15 - Aurora
15 - Aurora

The last thing that come to my mind:

 

You need to add your User to a Site and connect to the site - not to the Hub.

 

In our case we created a Site called 'Admins Personal Area' and we had to connect to:

 

https://[URL].com/Admins%20Personal%20Area 

 

You should be able to find your Site link somewhere on the Site-view itself.

CameronSteele
6 - Meteoroid
That is what I am currently trying. Thanks for the ideas!
grossal
15 - Aurora
15 - Aurora

Let me know if it worked. I can double check our settings later on if it doesn't work.

BryceL
Alteryx
Alteryx

Hi Cameron,

 

It sounds like you have gone through the steps I would expect to connect successfully from Designer. You will need to specify the URL including https:// and the site name in Designer or you will encounter the error you mention.  A couple additional thoughts:

  • Did you open the specified ports on the machine where you installed Hub?
  • Are there any spaces or characters in the site name that require encoding in the URL?
  • If you inspect the cert in your browser, does it have any errors?
    • Navigate to Hub URL
    • Click the lock icon in front of the URL
    • Certificate

Let me know if you are still having issues, and I'm happy to help troubleshoot further.

 

Thanks,

Bryce

CameronSteele
6 - Meteoroid

Thanks Bryce - I'm assuming I either have something wrong with the self signed SSL certs or it doesn't like me just using the server's public IP as the web page.  I'm happy to let you look at it as is if you're wanting to use my issues as feedback but my plan is to just wait till I have a time later this week or next to set up a real URL and real SSL cert.

Labels